Article Number
000035105
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: 7.0.0, 7.0.1 ,7.0.2
Issue
RSA Identity Governance & Lifecycle Identity Data Collector (IDC) collection shows status of Failed during the Identity Data Collection/Identity Data Unification step, as shown:
Image description
Under
Details for Run, if you select
Admin Errors, the detailed failure shows:
EC[918] Context[RunID=30947, IDC(Name=Active Directory, ID=5)}
Message[Unknown error code]
The aveksaServer.log file (/home/oracle/wildfly-8.2.0.Final/standalone/log/aveksaServer.log) shows the error ORA-00918: column ambiguously defined:
com.aveksa.server.xfw.ExecutionException: com.aveksa.server.collector.DataProcessorException: com.aveksa.server.db.PersistenceException: java.sql.SQLSyntaxErrorException:
ORA-00918: column ambiguously defined
ORA-06512: at "AVUSER.IDC_NORMALIZE", line 220
ORA-06512: at "AVUSER.IDC_DATA_COLLECTOR", line 105
ORA-06512: at "AVUSER.IDC_DATA_COLLECTOR", line 195
ORA-06512: at line 1
Cause
This is a known issue in in the following versions of RSA Identity Governance & Lifecycle:
- RSA Identity Governance & Lifecycle 7.0.0 P04
- RSA Identity Governance & Lifecycle 7.0.1 P01
- RSA Identity Governance & Lifecycle 7.0.2 GA version
This issue may occur during upgrade or patch when the customer has existing unified users that contains duplicates. If more than one IDC is defined, and the original attribute used to define the join criteria for the unification was not unique the unification may fail. Note that if a new unification is defined RSA Identity Governance & Lifecycle now prevents the unification from being defined in a manner that might lead to duplicate users.
Resolution
This issue is resolved in the following RSA Identity Governance & Lifecycle versions:
- RSA Identity Governance & Lifecycle 7.0.1 P03
- RSA Identity Governance & Lifecycle 7.0.2 P01
Customers using 7.0.0 P04 should upgrade to the latest patch on the 7.0.1 or 7.0.2 versions.
Workaround
There is no practicable work around for this issue. Contact
RSA customer support for additional guidance if you are unable to patch to a version where this issue is resolved.