Article Number
000037128
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Product/Service Type: Enterprise Software
RSA Version/Condition: 7.0.2 P11, 7.1.0 P01, P02 and P03
Issue
In RSA Identity Governance & Lifecycle, a scheduled report that is emailed as a Microsoft Excel spreadsheet is reporting the following error in the aveksaServer.log.
10/09/2018 07:15:38.376 ERROR (ThreadPool-4) [ReportRunnerTask] Failed to generate the report. Report Details: Report[id="211" name="Report: All User Access"], ReportResult[id="16843", report-id="211", save-date="Tue Oct 09 07:15:38 CEST 2018", fill-start-date="Tue Oct 09 07:00:00 CEST 2018", status="Completed", type="F", created-by-user="0", type-string="Fill Saved Temporary, should never see in UI", description="Scheduled Report", filter="null"], run-status="FAILED"]
java.lang.IllegalArgumentException: No enum constant com.aveksa.server.report.Report.SaveAsType.XLS
at java.lang.Enum.valueOf(Enum.java:238)
at com.aveksa.server.report.Report$SaveAsType.valueOf(Report.java:82)
Cause
Report Attachment File Types of .xls were not migrated to .xlsx after applying 7.0.2 P11, or after upgrading (migrating) to version 7.1.0 patches P01, P02 or P03.
Resolution
Apply the following patches:
Workaround
- For a single report, edit the report and change the attachment file type to xlsx:
- In the UI, navigate to Reports > Tabular.
- Click on the report name and click on the Edit button.
- Click on the Schedule and Email tab.
- In the Email section for the Attachment file type options, click on .xlsx (Excel Spreadsheet).
- Click OK.
Image description
- For multiple reports, please contact RSA Customer Support, who will confirm you have the issue, and provide SQL to update all the Report XLS Attachment File Types.