ORA-12899: value too large for column "AVUSER"."STX_450689643"."OBJECT_TYPE" when importing a coverage file into an RSA Identity Governance & Lifecycle Review
Originally Published: 2019-08-06
Last Modified: 2023-11-30
Article Number
Applies To
RSA Version/Condition: All
Issue
ORA-12899: value too large for column "AVUSER"."STX_450689643"."OBJECT_TYPE" (actual: 59, maximum: 50)
The following errors can be seen in the aveksaServer.log:
06/27/2019 14:35:43.103 ERROR (default task-24) [com.aveksa.gui.pages.review.definition.edit.coverage.UploadCoverageDataPageData]
com.aveksa.server.review.ReviewServiceException: Error while processing coverage file <br><br>ORA-12899: value too large for column "AVUSER"."STX_450689643"."OBJECT_TYPE" (actual: 59, maximum: 50)
at com.aveksa.server.review.ReviewServiceProvider.validateCoverageFile(ReviewServiceProvider.java:1695)
at com.aveksa.server.review.ReviewServiceProvider.validateReviewerCoverageFile(ReviewServiceProvider.java:1658)
Caused by: com.aveksa.server.db.PersistenceException: java.sql.BatchUpdateException: ORA-12899: value too large for column "AVUSER"."STX_450689643"."OBJECT_TYPE" (actual: 59, maximum: 50)
at com.aveksa.server.review.ReviewUtils.loadCoverageIntoTmpTable(ReviewUtils.java:155)
at com.aveksa.server.review.ReviewServiceProvider.validateCoverageFile(ReviewServiceProvider.java:1684)
... 65 more
Caused by: java.sql.BatchUpdateException: ORA-12899: value too large for column "AVUSER"."STX_450689643"."OBJECT_TYPE" (actual: 59, maximum: 50)
at oracle.jdbc.driver.OraclePreparedStatement.executeBatch(OraclePreparedStatement.java:12296)
at oracle.jdbc.driver.OracleStatementWrapper.executeBatch(OracleStatementWrapper.java:246)
at org.jboss.jca.adapters.jdbc.WrappedStatement.executeBatch(WrappedStatement.java:1190)
at com.aveksa.server.db.FileToTable.commitBatchToDB(FileToTable.java:397)
at com.aveksa.server.db.FileToTable.process(FileToTable.java:372)
at com.aveksa.server.review.ReviewUtils.loadCoverageIntoTmpTable(ReviewUtils.java:149)
com.aveksa.server.review.ReviewServiceException: Error while processing coverage file <br><br>ORA-12899: value too large for column "AVUSER"."STX_450689643"."OBJECT_TYPE" (actual: 59, maximum: 50)
at com.aveksa.server.review.ReviewServiceProvider.validateCoverageFile(ReviewServiceProvider.java:1695)
at com.aveksa.server.review.ReviewServiceProvider.validateReviewerCoverageFile(ReviewServiceProvider.java:1658)
Caused by: com.aveksa.server.db.PersistenceException: java.sql.BatchUpdateException: ORA-12899: value too large for column "AVUSER"."STX_450689643"."OBJECT_TYPE" (actual: 59, maximum: 50)
at com.aveksa.server.review.ReviewUtils.loadCoverageIntoTmpTable(ReviewUtils.java:155)
at com.aveksa.server.review.ReviewServiceProvider.validateCoverageFile(ReviewServiceProvider.java:1684)
... 65 more
Caused by: java.sql.BatchUpdateException: ORA-12899: value too large for column "AVUSER"."STX_450689643"."OBJECT_TYPE" (actual: 59, maximum: 50)
at oracle.jdbc.driver.OraclePreparedStatement.executeBatch(OraclePreparedStatement.java:12296)
at oracle.jdbc.driver.OracleStatementWrapper.executeBatch(OracleStatementWrapper.java:246)
at org.jboss.jca.adapters.jdbc.WrappedStatement.executeBatch(WrappedStatement.java:1190)
at com.aveksa.server.db.FileToTable.commitBatchToDB(FileToTable.java:397)
at com.aveksa.server.db.FileToTable.process(FileToTable.java:372)
at com.aveksa.server.review.ReviewUtils.loadCoverageIntoTmpTable(ReviewUtils.java:149)
Please refer to RSA Knowledge Base Article 000030327 - Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the log files for your specific deployment.
Cause
For example, the structure of a coverage file for a review is as follows:
<Reviewer/Monitor Filter>|<Subject Type>|<Subject Filter>|<Object Type>|<Object Filter>|<Privilege>
A legitimate sample entry could be as follows where the application name is Payroll.
user_id='009'|user|department='HR'|application|name='Payroll'|
What if the application name was 0025|Payroll as in:
user_id='009'|user|department='HR'|application|name='0025|Payroll'|
The use of the separator character (|) in the text field will cause this error.
Resolution
FROM:
user_id='009'|user|department='HR'|application|name='0025|Payroll'|
TO:
user_id='009'|user|department='HR'|application|name='0025%Payroll'|
Related Articles
C_SetCertBER returns error E_UNKNOWN_CRITICAL_EXTENSION 14Number of Views RSA Governance & Lifecycle Recipes: Generating Coverage Files from Reports 60Number of Views How does the Rules Agent Engine (rules.xml) processing work? 4Number of Views How to dynamically assign multiple reviewers in a review 10Number of Views installDatabaseOnly.sh script fails with error "No such file or directory" in RSA Governance & Lifecycle 110Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device RSA Governance & Lifecycle Generic Database Collector Guide RSA Authentication Manager 8.7 SP2 Administrator's Guide RSA Authentication Manager 8.9 Release Notes (January 2026) RSA Authentication Manager 8.9 Setup and Configuration Guide
Don't see what you're looking for?