Article Number
000036914
Applies To
RSA Product Set: Identity Governance & Lifecycle
RSA Version/Condition: 7.0.1, 7.0.2, 7.1.0 HF01.
Issue
The aveksaServer.log file repeatedly shows the following message.
10/24/2018 12:15:44.145 INFO (default task-24) [com.aveksa.afx.server.service.AFXServerAgentServiceProvider] updateServerAgentUptimeDate: Setting new uptime for server agent 1, creating a new record with 2018-10-24 11:15:39.0 - '
prior uptime date: Wed Oct 24 11:13:28 BRST 2018, prior last polled date: Wed Oct 24 11:15:25 BRST 2018, last polled date: 2018-10-24 11:15:39.0, current date: 2018-10-24 11:15:39.0, polling interval 5000
Cause
This message is a symptom of multiple sessions locking table T_AV_AFX_SERVER_AGENT.
RSA Identity Governance & Lifecycle is attempting to update the uptime, but it cannot because the table is locked, but then tries again after four to five minutes.
The cause has been identified as defect ACM-85871 - AFX goes into "not running" and connectors go into "stopped" state due to locks on t_av_afx_server_agent table
Resolution
Upgrade to RSA Identity Governance & Lifecycle version 7.1.0 P03, where defect ACM-85871 has been fixed.
Workaround
The locks on table T_AV_AFX_SERVER_AGENT can be released by restarting the AVDB database.
Make sure that there are no other users using the application.
- Login as the oracle user.
- Issue the following commands.
afx stop
acm stop
acm stopdb
acm startdb
acm start
afx start
Notes