Article Number
000035667
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Version/Condition: All
Issue
After an upgrade and subsequent migration of the database or after applying a patch, the RSA Identity Governance & Lifecycle startup fails with the following
Initialization Status error:
Initialization operations completed with errors. Please resolve the problem(s) before the application server can accept requests.
Found invalid objects in the database. Please check the log file for error(s).
Image description
The following error is logged to the
aveksaServer.log file
($AVEKSA_HOME/wildfly/standalone/log/aveksaServer.log):
10/20/2017 15:14:59.887 ERROR (MSC service thread 1-9) [com.aveksa.migration.jdbctool.CheckDatabase]
Found invalid object(s) in the database. Please check the log for error(s).
10/20/2017 15:14:59.937 INFO (MSC service thread 1-9) [com.aveksa.server.runtime.AveksaSystem]
******************** Aveksa System Initialization End ********************
10/20/2017 15:14:59.938 FATAL (MSC service thread 1-9) [com.aveksa.server.runtime.AveksaSystem]
****************************************
Initialization has failed!
Found invalid object(s) in the database. Please check the log for error(s).
Please refer to RSA Knowledge Base Article
000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the
aveksaServer.log file for your specific deployment if you are on a WildFly cluster or a non-WildFly platform.
Cause
There are objects in the database that have not compiled cleanly.
Resolution
To check which objects are invalid, execute the following query as
avuser:
select * from user_objects where status='INVALID';
If any rows are returned, note the object name(s) and recompile the object(s) individually or run the following procedure as
avuser:
exec AV_Compile_Invalid_Objects
Check for invalid objects again:
select * from user_objects where status='INVALID';
If you still have invalid objects, check whether the objects are RSA Identity Governance & Lifecycle database objects. If yes, please contact
RSA Identity Governance & Lifecycle Support for further assistance on this issue and mention this RSA Knowledge Base Article ID 000035667 for reference.
If the invalid objects are non RSA Identity Governance & Lifecycle objects, you will need to recompile those objects or uninstall the product they are associated with or contact the product vendor for assistance. For example, we have seen customers install COGNOS as a SQL reporting tool into the
avuser schema. If this application has an invalid object, migration and/or patching will fail until the COGNOS object(s) is recompiled or the COGNOS product is removed. For assistance on recompiling COGNOS objects, please contact COGNOS support.
Notes
WARNING: This KB article is for a very specific issue. If the symptoms/errors and product versions do not match exactly with the issue on your system, do not use this article.
This article is intended to be used when a single or perhaps a few very specific objects generates the error. If there are many objects generating this error do not use this article.
Note that if there is a general problem with the database as the result of a catastrophic failure then the most common symptom is a general failure compiling one or more arbitrary objects in the database. Do not use this article for these use cases.