Article Number
000037239
Applies To
RSA Product Set: RSA Identity Governance & Lifecycle
RSA Product/Service Type: Enterprise Software
RSA Version/Condition: 7.1.1, 7.1.0, 7.0.2
Issue
In RSA Identity Governance & Lifecycle, after requesting an entitlement for a user, the Outstanding Requests screen is presented to the user. The screen shows the following message, but the screen shows an empty list with 0 items
There are outstanding requests involving the changes shown below. Select any changes you still wish to submit.”
If an attempt is made to submit the request a warning dialog is displayed:
This request contains no changes. It cannot be submitted.
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Cause
This issue occurs if a request is made for an entitlement for a user where the user does not have the entitlement, but the user is a member of a role where that entitlement is part of the role. It occurs if the request form for the application has the Check outstanding requests option enabled (default).
For direct entitlements, before allowing a request to be created, RSA Identity Governance & Lifecycle checks to see if there are any pending requests for these entitlements. For indirect entitlements belonging to a Role we also check to see if the role has also been provisioned directly. This check incorrectly displays the error as shown.
Resolution
This issue is resolved in the following patches. The product no longer checks to see if the user is provisioned for the role.
- RSA Identity Governance & Lifecycle 7.0.2 P13
- RSA Identity Governance & Lifecycle 7.1.0 P07
- RSA Identity Governance & Lifecycle 7.1.1 GA
Workaround
In the Application Form you can disable the “Check outstanding requests” option. This only works if the application uses a custom form as the default form is not editable.
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