Article Number
000017043
Issue
The installer was unable to set required configuration data. Ensure that the owner of the $user.home/InstallShield and $user.home/InstallShield/Universal folders is the same as the user that installed RSA Authentication Manager.
Cause
Not logged in as the proper user
permissions on installation files incorrect
the proper path for the user's home directory is not available, or not proper permissions
insufficient disk space in the user's home directory, or in /tmp
Resolution
Check (RSAHome)/utils/rsaenv.cmd , look for a line:
SET CLU_USER=xxxxxxxx
This xxxxxxxx must be the original installation username, and you must be logged in as this username when installing the patch.
Check /etc/passwd , there needs to me a line for the installation user similar to:
username:x:513:513:comment:/home/username:/bin/bash
check that /home/username exists , and that permissions are open to username. If there are directories /home/username/Installshield and/or /home/username/Installshield/Universal , verify permissions are correct.
The zipfile with the patch or service pack must be unzipped as the installation user username. If it is not, create a directory as root, and copy the zipfile to this directory. Change ownership of the directory and zipfile to the installation user, and permissions to 777.
Change to the installation user, and unzip the file.
After the installation files exist and are unzipped, make sure at least 2GB of space remain in the partitions that have /home and /tmp . If installing a Service pack instead of a patch, make sure at least 4GB exist in these partitions, and enough space in the (RSAHome) partition to create a restore point.