Authentication Manager 8.x ./rsautil store -a update_config gives WARNING cannot find the config name
Originally Published: 2018-10-16
Last Modified: 2022-06-20
Article Number
Applies To
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x all versions
Issue
The issue is, when you follow the steps in these articles, you can get the following warning:
rsaadmin@am82r1:/opt/rsa/am/utils> ./rsautil store -a update_config auth_manager.extend_token_life.token_days_for_expiration 16 GLOBAL 503
Please enter OC Administrator username: <enter Operations Console user name>
Please enter OC Administrator password: <enter Operations Console user password>
psql.bin:/tmp/b9296f16-c0c4-407c-8ef1-6db9cfcfbe531604505986452836533.sql:167: WARNING: Unable to update the value: cannot find the config name 'auth_manager.extend_token_life.token_days_for expiration' for the host instance 'GLOBAL'.
update_config
---------------
(1 row)
rsaadmin@am82p:/opt/rsa/am/utils>
Cause
Running the ./rsautil store ? command provides the following output:
rsaadmin@am82r1:/opt/rsa/am/utils> ./rsautil store ?
Usage: rsautil store -a <action> -o <Operations Console (OC) Username> -p <Operations Console (OC) password>
Options:
-o, --oc-user Operations Console (OC) administrator user name.
-p, --oc-user-pw Operations Console (OC) administrator password.
-h, --help prints help message and exits.
-v, --version prints version information and exits.
-V, --verbose enable verbose output. Optional.
-a, --action (one of the following)
add_config <name> <value> <hostname> <data_type> Create a new config parameter.
NOTE: Prior versions of this command expected INSTANCE NAME rather than HOST NAME as the third parameter. You can also use keyword GLOBAL for the hostname argument in the case of global config parameter.
Data_type: Accepts values of type INTEGER, BOOLEAN, STRING, DATE and Numeric value data types supported in AM 8.0(example 511 for enum type).
enable_min_protocol_tlsv1_2 <isEnableProtocol> This command enables or disables the TLS 1.2 protocol.
NOTE: *******To re-start the services automatically, use the optional argument 'restart' **********
Data_type: Accepts values of type BOOLEAN.
update_config <name> <value> <hostname> Set config parameters.
NOTE: Prior versions of this command expected INSTANCE NAME rather than HOST NAME as the third parameter. You can also use keyword GLOBAL for the hostname argument in the case of global config parameter.
Usage: rsautil store -a <action> -o <Operations Console (OC) Username> -p <Operations Console (OC) password>
Options:
-o, --oc-user Operations Console (OC) administrator user name.
-p, --oc-user-pw Operations Console (OC) administrator password.
-h, --help prints help message and exits.
-v, --version prints version information and exits.
-V, --verbose enable verbose output. Optional.
-a, --action (one of the following)
add_config <name> <value> <hostname> <data_type> Create a new config parameter.
NOTE: Prior versions of this command expected INSTANCE NAME rather than HOST NAME as the third parameter. You can also use keyword GLOBAL for the hostname argument in the case of global config parameter.
Data_type: Accepts values of type INTEGER, BOOLEAN, STRING, DATE and Numeric value data types supported in AM 8.0(example 511 for enum type).
enable_min_protocol_tlsv1_2 <isEnableProtocol> This command enables or disables the TLS 1.2 protocol.
NOTE: *******To re-start the services automatically, use the optional argument 'restart' **********
Data_type: Accepts values of type BOOLEAN.
update_config <name> <value> <hostname> Set config parameters.
NOTE: Prior versions of this command expected INSTANCE NAME rather than HOST NAME as the third parameter. You can also use keyword GLOBAL for the hostname argument in the case of global config parameter.
If you run add_config, but the name already exists in the system, the error you will see is:
ERROR: The config already exists
If the update_config parameter does not exist, the following warning displays:
WARNING: cannot find the config name <name>
Resolution
The WARNING: Unable to update the value: cannot find the config name '<name>' for the host instance 'GLOBAL' message is an indication that the value does not exist and must first be created with the add_config command, as in the example below:
rsaadmin@am82r1:/opt/rsa/am/utils> ./rsautil store -a add_config auth_manager.extend_token_life.token_days_for_expiration 16 GLOBAL 503
Please enter OC Administrator username: <enter Operations Console user name>
Please enter OC Administrator password: <enter Operations Console user password>
psql.bin:/tmp/5a6fe8e9-d36a-478e-86c9-84e1a34dc7965982186461118251238.sql:108: NOTICE: Added the new configuration parameter "auth_manager.extend_token_life.token_days_for_expiration" with the value "16"
update_config
---------------
(1 row)
rsaadmin@am82r1:/opt/rsa/am/utils>
Please enter OC Administrator username: <enter Operations Console user name>
Please enter OC Administrator password: <enter Operations Console user password>
psql.bin:/tmp/5a6fe8e9-d36a-478e-86c9-84e1a34dc7965982186461118251238.sql:108: NOTICE: Added the new configuration parameter "auth_manager.extend_token_life.token_days_for_expiration" with the value "16"
update_config
---------------
(1 row)
rsaadmin@am82r1:/opt/rsa/am/utils>
Likewise, if you try to run ./rsautil store -a add_config and get ERROR: The config already exists, then use ./rsautil store -a update_config to modify this override variable
Notes
Related Articles
Cannot Find Job ID Workflow Variable 33Number of Views Error 'Cannot find Secure Directory Server!' when starting RSA Certificate Manager 9Number of Views When you run the lsdata -statistics is the number given uncompressed? 29Number of Views How can a connection authenticated through RSA ACE/Server be terminated if idle for a given time? 12Number of Views Installation of RSA Identity Governance & Lifecycle 7.0.2 fails during WildFly install/config phase with jboss-modules.jar… 136Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device RSA Governance & Lifecycle Generic Database Collector Guide RSA Authentication Manager 8.7 SP2 Administrator's Guide RSA Authentication Manager 8.9 Release Notes (January 2026) RSA Authentication Manager 8.9 Setup and Configuration Guide
Don't see what you're looking for?