Article Number
000029020
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.0 or 8.1
Issue
Symptoms include:
- Performing a migration from RSA Authentication Manager 6.1 to Authentication Manager 8.x.
- The RADIUS migration option is completed prior to migrating the Authentication Manager database.
- When performing the Authentication Manager server migration, the option for Test Migration is checked.
- The test migration fails immediately and throws the following error in the /opt/rsa/am/server/logs/migration_basic-<datestamp>/migrationReport.log:
Exception thrown during migration job befc9f71bf01010a1ae6a3d101e9dd75
java.lang.NullPointerException
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.AgentMigrationTask.linkToRADIUSClientIfNeeded(AgentMigrationTask.java:607)
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.AgentMigrationTask.processRecord(AgentMigrationTask.java:577)
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.AgentMigrationTask.executeBatch(AgentMigrationTask.java:134)
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.AbstractMigrationTask$MigrationTaskTransactionTemplate.doInTransaction(AbstractMigrationTask.java:829)
at org.springframework.transaction.support.TransactionTemplate.execute(TransactionTemplate.java:130)
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.AbstractMigrationTask.completeTask(AbstractMigrationTask.java:355)
at com.rsa.authmgr.internal.admin.acemigrate61.impl.task.MigrationTaskChainImpl.executeNext(MigrationTaskChainImpl.java:26)
- The /opt/rsa/am/server/logs/imsTrace.log lists following error:
2014-11-04 19:35:30,463, [[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'], (AgentAccessSQL.java:71),
trace.com.rsa.authmgr.internal.admin.common.dal.sql.DataObjectAccessSql, ERROR, <FQDN_of_primary_Authentication_Manager_server>,,,,
Unable to lookup class com.rsa.authmgr.internal.admin.agentmgt.dal.Agentwith ip address: <IP_address_of_primary_Authentication_Manager_server>
Cause
The test migration fails because the RADIUS agent is not yet in the database, but the test migration attempts to look up the RADIUS agent in the database to link with the RADIUS client.
Resolution
To resolve the issue,
- Take a backup of the blank database via the Operations Console, if using a hardware appliance, or take a snapshot of the virtual server.
- Skip the test migration option and do a real database migration.
Optionally, cleanup all the migrated RADIUS clients, do the Authentication Manager database migration first, then perform the RADIUS migration.