Article Number
000029663
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
Platform: VMware
Issue
When trying to install Authentication Manager 8.x, and choosing the license file, the following error is displayed:
The submitted license file is not compatible. Upload a license file compatible with the product version 8.x.
Cause
This error displays when trying to install a license for a newer version of RSA Authentication Manager on server running an older version of Authentication Manager.
The license zip file will typically include at least these files:
- defaultRSAToolbar.cer;
- defaultRSAToolbar.key;
- sdti.cer;
- server.cer;
- server.key; and
- One or more .xml file(s) for the license itself. The format of the file name could be something like 12345678_10_20140123.xml
Resolution
To resolve this error:
- Extract the license zipfile .
- Copy all of the extracted files to another directory.
- Check each of the .xml files for the license:productVersion to see the version for which it was built. An example of the line:
<license:productVersion>8.3</license:productVersion>
The mention of 8.3 above shows the license is for RSA Authentication Manager 8.3. Authentication Manager supports licenses made for its version or older. If you try to install a license for Authentication Manager 8.4 on a server running Authentication Manager 8.3, it will fail.
- Delete any of the Authentication Manager 8.4 or newer files from the copy made in step 2.
- Make a new zip file that includes all of the remaining files. Use this to install Authentication Manager 8.3.
Notes
Once the installation has finished, update to Authentication Manager 8.4, so that the remaining Authentication Manager 8.4 licenses can be imported into the primary. With a replica, this information should automatically propagate from the primary.