Article Number
000037744
Applies To
RSA Product Set: SecurID Access
RSA Product/Service Type: Identity Router (IDR)
Issue
This article explains the use case of failure of RSA SecurID Access IDR registration when using a proxy server from the IDR management console to connect to the CAS server for registration.
The following error is seen:
Checking for connection for authentication and product maintenance with error Cannot connect to cloud authentication service
Cause
The symplified.log shows that the proxy ID credentials used are causing this failure:
Error code: Connection failed
Error message: Couldn't resolve proxy 'IDacc0unt@abcproxy.abc.com'
The
@ character in the password was being parsed incorrectly
The credentials are passed to the proxy server in the format
<username>:<password>@<proxyhostname>.
Because of the additional @ character in the password, it was unable to resolve the proxy hostname correctly.
Image description
Resolution
Use a different user credential which does not have @ as one of the character in the password to register the IDR successfully.