Article Number
000068139
Applies To
RSA Product Set: SecurID Access
RSA Product/Service Type: Cloud Authentication Service
Issue
When logging to Anypoint, the user is redirected to RSA for authentication as expected. However, login fails with the below generic error. The Tracer does not log any errors, and the User Event Monitor is showing the successful generation of the Access Token.
The request could not be processed at this time
Cause
The Client Authentication Method was incompatible. As per the documentation, Anypoint supports HTTP Basic Authentication, which is the CLIENT_SECRET_BASIC Method.
Reference: Anypoint Authentication Methods
Resolution
1. Login to the Cloud Administration Console as a Super Admin
2. Navigate to Authentication Clients => Relying Parties
3. Edit the Anypoint application
4. Navigate to Connection Profile
5. Under Authorization Code Flow, Client Authentication Method, select CLIENT_SECRET_BASIC
6. Save and Publish Changes
Image description
Workaround
N/A
Notes
N/A