Article Number
000037073
Applies To
RSA Product Set: SecurID Access
RSA Product/Service Type: Identity Router
Issue
The RSA SecurID Access Identity Router (IDR) Setup Console is used to configure and manage an IDR. To access the Setup Console:
- For Amazon cloud-based identity routers, go to https://<identityrouterIP>:9786/setup.jsp, where <identityrouterIP> is the private IP address of the identity router.
- For VMware and Hyper-V identity routers, go to https://<identityrouterIP>/setup.jsp, where <identityrouterIP> is the IP address of the identity router management interface.
When accessing one of the Setup Console's pages, occasionally the following error is displayed:
Service Temporarily Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
This most often happens when displaying the IDR Setup Console's Network Diagnostics page (
Diagnostics >
View Network Diagnostics). However, the problem can also happen on any other page of the Setup Console.
Cause
The issue is caused by a temporary delay within the IDR when preparing the data for the requested web page. An HTTP 503 error occurs due to an internal timer within the IDR, which is configured to allow a maximum time of 20 seconds.
The problem most often happens on the Network Diagnostics page, because the time required to retrieve all the network diagnostics data sometimes exceeds the 20 second timer threshold
Workaround
This issue should only happen infrequently. To workaround the problem, try the following:
- Click your web browser's Refresh button to re-display the page. It should take no more than two or three attempts to display the required page correctly.
- If it takes more than just a few attempts to display the required page, check if the IDR is performing some unusual activity, such as processing a Publish request from the Cloud, or doing Identity Source synchronization. If that is occurring, wait until the function has completed, then try to display the page again.
- Check the underlying virtualization platform (VMware, Hyper-V or AWS) for possible performance issues. Ensure the underlying platform is providing sufficient processing capacity (CPU, memory, disk I/O, etc.) to meet the IDR's requirements.