Article Number
000035766
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.1 SP1 or later
Issue
The software update installer fails applying the update.
The update log file (e. g., update-8.2.1.6.0-build1396313-yyyymmddhhmmss.log) located in the /opt/rsa/am/server/logs folder reports the following message:
252313 2017-11-22 14:18:14,137 FATAL: Replication flush failed. Unable to process all pending changesets from: /opt/rsa/am/replication/r2p_chgsets_to_apply.
java.lang.AssertionError: Replication flush failed. Unable to process all pending changesets from: /opt/rsa/am/replication/r2p_chgsets_to_apply.
Cause
There is a replication failure (such as the Authentication Manager primary and replica(s) being out of sync) where replica change sets are still waiting to be processed in the /opt/rsa/am/replication/r2p_chgsets_to_apply folder.
Resolution
Replication is expected to be working to apply an authentication manager software update. Where replication has failed and the replica instance is out-of-sync with the primary instance an administrator can manually remove the data from the /opt/rsa/am/replication/r2p_chgsets_to_apply folder.
The administrator should confirm the Authentication Manager services are running before applying the software update again.
Commands to use at the command line with the rsaadmin account:
- Removing data from the folder:
rm -rf /opt/rsa/am/replication/r2p_chgsets_to_apply/*
- Check that the folder is empty:
ls -l /opt/rsa/am/replication/r2p_chgsets_to_apply
- Check Authentication Manager services:
/opt/rsa/am/server/rsaserv status all
- Start the Authentication Manager services (if required):
/opt/rsa/am/server/rsaserv start all
Notes