Article Number
000067875
Applies To
RSA Product Set: SecurID Access
RSA Product/Service Type: SecurID Access Prime
Issue
Registering the Authenticate app with the Cloud Authentication Service (CAS) using the Prime Self-Service Portal (SSP) succeeds, but attempting to register the new SecurID app with the CAS using the SSP fails.
Cause
The /opt/rsa/primekit/configs/amis/workflow-config.xml file on the Prime server(s) needs to be updated to allow for registering the new SecurID app with the Cloud Authentication Service using the Self-Service Portal.
Resolution
Do the following for each Prime server:
- Log into the Prime server as the primekit user.
- Navigate to the /opt/rsa/primekit/configs/amis directory.
- Linux: cd /opt/rsa/primekit/configs/amis
- Make a backup copy of the workflow-config.xml file in this directory.
- Linux: cp workflow-config.xml workflow-config.xml.backup
- Edit the workflow-config.xml file.
- Linux: vi workflow-config.xml
- In the workflow-config.xml file, find and modify the <mobileActivation> section to be the following:
<mobileActivation>
<cloudActivateApiKey>${mobile.api.key}</cloudActivateApiKey>
<cloudActivateUrl>${mobile.activation.api.endpoint}</cloudActivateUrl>
<companyID>${mobile.companyID}</companyID>
<!-- Subsition syntax for url can use $[activationCode], $[companyID], $[userID] or $[userEmail] -->
<mobileUrls defaultActivationUrl="com.rsa.via://enroll?data=$[activationCode]">
<!--Android listener/prefix removed for compatibility with SecurID App 4.0 -->
<!--<device name="Android" url="http://127.0.0.1/via/enroll?data=$[activationCode]"/>-->
<device name="Android" url="$[activationCode]"/>
<!--iOS listener/prefix removed for compatibility with SecurID App 4.0 -->
<!--<device name="iOS" url="com.rsa.via://enroll?data=$[activationCode]"/>-->
<device name="iOS" url="$[activationCode]"/>
<device name="Windows.10" url="com.rsa.via://enroll?data=$[activationCode]"/>
</mobileUrls>
</mobileActivation> 6. Save the updated
workflow-config.xml file.
7. Restart the AMIS service.
- Linux: service tomcat-amis restart
8. Restart the SSP service.
- Linux: service tomcat-ssp restart
9. Attempt to register the SecurID app with the Cloud Authentication Service using the Self-Service Portal again.
Notes
If the steps in the "Resolution" section do not resolve the issue, the Prime WAR files on the Prime server(s) may need to be updated as well. Please contact RSA Support for further assistance troubleshooting.