Access denied error while running the RSA Authentication Manager 8.x Administration SDK
Originally Published: 2020-02-06
Last Modified: 2022-06-20
Article Number
Applies To
RSA Product/Service Type: Authentication Manager SDK
RSA Version/Condition: 8.x
Issue
ERROR: com.rsa.authn.AuthenticationCommandException: Access Denied
at com.rsa.authn.AuthenticatedTargetImpl.login(AuthenticatedTargetImpl.java:172)
at com.rsa.command.ConnectionFactory$ConnectionImpl.connect(ConnectionFactory.java:758)
at com.rsa.command.ConnectionFactory$ConnectionImpl.connect(ConnectionFactory.java:740)
at com.rsa.samples.admin.AdminAPIDemos.main(AdminAPIDemos.java:1373)
Cause
- The Security Console administrator is not a member of the internal database, but rather, belongs to an external identity source.
- The user entered invalid Security Console login credentials, such as an invalid username or password.
Resolution
Create a super admin in the internal database
- Log in to the Security Console with a super admin user.
- Go to Identity > Users > Add New.
- Create a user by filling out all required fields and other details, if needed.
- Click Save.
- Go to Administration > Administrative Roles > Manage Existing.
- Scroll to SuperAdminRole and from the context arrow, select Assign More.
- Search for the new user created in step 3.
- Place a check in the box next to the user ID and click Assign to Role.
Submit the correct credentials into the SDK
If you are using the SDK sample code as discussed in 000034753 - Configure RSA Authentication Manager 8.x software developer kit (SDK), then the Program Arguments consists of three inputs, which are separated by spaces. The first input is the action (for example, create, assign, list-users, etc.). The second is the name of the new super admin created above. The third input is that user's password. For example,[Program Arguments] list-users superadmin P@55w0rd
Notes
Related Articles
?KMClient: Error getting key from KMS: Error from server: Access Denied? 28Number of Views Errors 'Server Timeout' and 'User TIME's access is denied' with RSA Access Manager and RSA SecurID 182Number of Views "Access Denied" error when attempting to view detailed information on the RSA Via Lifecycle and Governance Users page 69Number of Views Error message "Access denied - User not a member of any identity source in access policy" in RSA SecurID Access 81Number of Views User name included in RADIUS response packet in RSA ACE/Server; 'Passcode Accepted' message followed 'Access Denied' and '… 39Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?