After patching to RSA Identity Governance & Lifecycle 7.0.2 P03+, emails are not generated and sent due to the error 'Illegal hex characters in escape (%) pattern'
Originally Published: 2018-03-21
Last Modified: 2023-12-01
Article Number
Applies To
RSA Version/Condition: 7.0.2 P03+, 7.1.0
Issue
After patching to RSA Identity Governance & Lifecycle 7.0.2 P03 or higher patch versions, emails are neither generated nor sent, due to the following error:
Illegal hex characters in escape (%) pattern
You will find the error below in the aveksaServer.log, which can be downloaded by navigating to Admin > System > Server Nodes > aveksaServer.log :
03/12/2018 17:01:11.643 ERROR (Worker_actionq#Script Queue - Normal#WPDS_7057) [com.aveksa.server.workflow.scripts.nodes.SendEmailThread] Couldn't Send Email to due to:
java.lang.IllegalArgumentException: URLDecoder: Illegal hex characters in escape (%) pattern - For input string: "; "
at java.net.URLDecoder.decode(URLDecoder.java:192)
at com.aveksa.server.workflow.scripts.nodes.SendEmailThread.getBody(SendEmailThread.java:109)
at com.aveksa.server.workflow.scripts.nodes.SendEmailThread.sendEmail(SendEmailThread.java:146)
at com.aveksa.server.workflow.scripts.nodes.SendEmailThread.sendEmail(SendEmailThread.java:66)
at com.aveksa.server.workflow.scripts.nodes.SendEmailNode.nodeAvailableAsynchronous(SendEmailNode.java:34)
at com.aveksa.server.workflow.scripts.nodes.WorkflowNodeHandler.nodeAvailableAsynchronous(WorkflowNodeHandler.java:52
Cause
Resolution
If you're using ONLY email nodes in the workflows, you may apply 7.0.2 P07. If you're using approval, etc. with email in the workflows, apply 7.0.2 P08, as it contains fixes for all other nodes.
Workaround
- Replace the % character with %25, or
- Remove the percent sugn completely in the email content of the Send Email node.
Note that this workaround only affects change requests created after the edit to the workflows is made. Existing change requests are not corrected.
Related Articles
Salesforce Collector is throwing 'Invalid Credentials' error after patching to RSA Governance & Lifecycle 8.0.0 P06 8Number of Views In RSA Identity Governance & Lifecycle 7.0.1, Review Reminder email sent out before configured period has elapsed 10Number of Views "ORA-06575: Package or function ROLE_MANAGEMENT_PKG is in an invalid state" after patching to 7.5.2 P08 in RSA Governance … 36Number of Views After patching a Request Could Not be Handled error appears when pressing Edit Log Settings for Connectors in RSA Governan… 3Number of Views When multi-step review is generated, NewReviewGeneratedEvent is triggered twice for second step review sending duplicate e… 49Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?