Aveksa Hardware Appliance did not start after a reboot
2 years ago
Originally Published: 2016-04-11
Article Number
000064613
Applies To
RSA Product Set: Identity Management and Governance
RSA Product/Service Type: Appliance
RSA Version/Condition: 6.9.1
Platform: Linux
Platform (Other): null
O/S Version: SUSE Linux 10
Product Name: null
Product Description: null
Issue
The appliance will not start after a reboot. The SuSE screen may show:
"Starting RSA IMG Appliance Updater Service ... Logging to /var/log/rsaimg_updater.log"
but does not advance. There may be no error messages

 
Cause
The disk on the appliance is full.
Resolution
You will need to use an alternate startup process to get the Linux OS started, and be able to login as root. Follow this KB:
000031358  RSA VIA L&G / IMG / Aveksa - How to reset root's password on a SUSE based hardware appliance
but do NOT actually reset the root password, you are only doing this to be able to login by command-line as root.

Check the disk space:
acm-691:~ # df -m
Filesystem              1M-blocks  Used Available Use% Mounted on
/dev/mapper/system-root    226997 226997        0 100% /
udev                         7977     1      7977   1% /dev
tmpfs                        7977   200      7778   3% /dev/shm
/dev/sda1                     144    36       101  27% /boot


In this example, the drive is 100% full

Determine which files  can be safely moved elsewhere and deleted. Some examples are backups , old log files, old patch installers. If there are other unusual or non-standard large files or directories in a particular environment, these can also be considered. 
Reboot
 
Notes
This process can also be used to logon to an appliance when you normally cannot for other reasons. You can then troubleshoot, get logs, etc.