RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.7 SP2 or later
Operation Console displays a System Internal Error message in the web browser when an administrator attempts to restore an Authentication Manager backup.
For example:
The /opt/rsa/am/server/logs/ops-console.log reports the following error when an administrator attempts to restore an Authentication Manager backup:
@@@2026-06-22 14:20:53,187 ERROR [[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'] GUILog.traceException(607) | exception:
com.rsa.common.SystemException: java.io.UncheckedIOException: java.nio.file.AccessDeniedException: /opt/rsa/am/radius/control-socket
at com.rsa.ims.web.operationsconsole.action.BackupAction.restoreBackup(BackupAction.java:1102)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.struts.actions.DispatchAction.dispatchMethod(DispatchAction.java:269)
at com.rsa.ui.common.struts.action.RSABaseDispatchAction.execute(RSABaseDispatchAction.java:180)
at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:425)
at com.rsa.ui.common.util.RSAWebRequestProcessor.process(RSAWebRequestProcessor.java:221)
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1926)
at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:464)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:665)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:750)
at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:295)
at weblogic.servlet.internal.StubSecurityHelper$ServletServiceAction.run(StubSecurityHelper.java:260)
at weblogic.servlet.internal.StubSecurityHelper.invokeServlet(StubSecurityHelper.java:137)
at weblogic.servlet.internal.ServletStubImpl.execute(ServletStubImpl.java:353)
at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:25)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:82)
at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:100)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:82)
at com.rsa.ui.common.filter.I18NFilter.doFilter(I18NFilter.java:96)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:82)
at com.rsa.ui.common.security.csrf.CSRFFilter.doFilterInternal(CSRFFilter.java:200)
at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:106)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:82)
at com.rsa.ui.common.filter.UrlValidationFilter.doFilter(UrlValidationFilter.java:246)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:82)
at com.rsa.ims.common.operationsconsole.security.filter.CommonOCIMSSignOnFilter.doFilter(CommonOCIMSSignOnFilter.java:127)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:82)
at com.rsa.ims.common.operationsconsole.security.filter.CommonOCSignOnFilter.doFilter(CommonOCSignOnFilter.java:107)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:82)
at com.rsa.ims.sso.filter.HeaderValidationFilter.doFilter(HeaderValidationFilter.java:191)
at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:82)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.wrapRun(WebAppServletContext.java:3869)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:3832)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:344)
at weblogic.security.service.SecurityManager.runAsForUserCode(SecurityManager.java:197)
at weblogic.servlet.provider.WlsSecurityProvider.runAsForUserCode(WlsSecurityProvider.java:203)
at weblogic.servlet.provider.WlsSubjectHandle.run(WlsSubjectHandle.java:71)
at weblogic.servlet.internal.WebAppServletContext.processSecuredExecute(WebAppServletContext.java:2505)
at weblogic.servlet.internal.WebAppServletContext.doSecuredExecute(WebAppServletContext.java:2354)
at weblogic.servlet.internal.WebAppServletContext.securedExecute(WebAppServletContext.java:2329)
at weblogic.servlet.internal.WebAppServletContext.execute(WebAppServletContext.java:2307)
at weblogic.servlet.internal.ServletRequestImpl.runInternal(ServletRequestImpl.java:1800)
at weblogic.servlet.internal.ServletRequestImpl.run(ServletRequestImpl.java:1754)
at weblogic.servlet.provider.ContainerSupportProviderImpl$WlsRequestExecutor.run(ContainerSupportProviderImpl.java:274)
at weblogic.invocation.ComponentInvocationContextManager._runAs(ComponentInvocationContextManager.java:352)
at weblogic.invocation.ComponentInvocationContextManager.runAs(ComponentInvocationContextManager.java:337)
at weblogic.work.LivePartitionUtility.doRunWorkUnderContext(LivePartitionUtility.java:57)
at weblogic.work.PartitionUtility.runWorkUnderContext(PartitionUtility.java:41)
at weblogic.work.SelfTuningWorkManagerImpl.runWorkUnderContext(SelfTuningWorkManagerImpl.java:651)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:420)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:360)
Caused by: java.io.UncheckedIOException: java.nio.file.AccessDeniedException: /opt/rsa/am/radius/control-socket
at org.apache.commons.io.function.Uncheck.wrap(Uncheck.java:339)
at org.apache.commons.io.function.Uncheck.get(Uncheck.java:199)
at org.apache.commons.io.FileUtils.sizeOfDirectory(FileUtils.java:2952)
at com.rsa.ims.web.operationsconsole.action.BackupAction.hasEnoughDBSpaceForRestore(BackupAction.java:1278)
at com.rsa.ims.web.operationsconsole.action.BackupAction.restoreBackup(BackupAction.java:1093)
... 53 more
Caused by: java.nio.file.AccessDeniedException: /opt/rsa/am/radius/control-socket
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84)
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)
at sun.nio.fs.UnixFileSystemProvider.newDirectoryStream(UnixFileSystemProvider.java:427)
at java.nio.file.Files.newDirectoryStream(Files.java:457)
at java.nio.file.FileTreeWalker.visit(FileTreeWalker.java:300)
at java.nio.file.FileTreeWalker.next(FileTreeWalker.java:372)
at java.nio.file.Files.walkFileTree(Files.java:2706)
at java.nio.file.Files.walkFileTree(Files.java:2742)
at org.apache.commons.io.file.PathUtils.visitFileTree(PathUtils.java:1654)
at org.apache.commons.io.file.PathUtils.countDirectory(PathUtils.java:349)
at org.apache.commons.io.file.PathUtils.sizeOfDirectory(PathUtils.java:1592)
at org.apache.commons.io.FileUtils.lambda$sizeOfDirectory$15(FileUtils.java:2952)
at org.apache.commons.io.function.Uncheck.get(Uncheck.java:197)
... 56 more
The error reported in the /opt/rsa/am/server/logs/ops-console.log was due to incorrect permissions on the /opt/rsa/am/radius/control-socket folder.
The command to view the ownership and permissions of the /opt/rsa/am/radius/control-socket folder:
ls -ld /opt/rsa/am/radius/control-socket
The /opt/rsa/am/radius/control-socket folder ownership and permissions are expected to be the following:
rsaadmin@am88:~> ls -ld /opt/rsa/am/radius/control-socket/
drwxr-xr-x 2 root root 4096 Jun 23 14:52 /opt/rsa/am/radius/control-socket/
rsaadmin@am88:~>
- First character (d) refers to a directory
- Permissions (rwxr-wr-w) are grouped in three sets:
Meaning: - Number (2) is the link count.
- Ownership (root root)
- first root = owner (user)
- second root = group
The command to correct the permissions of the /opt/rsa/am/radius/control-socket folder:
sudo chmod 755 /opt/rsa/am/radius/control-socket
The command to correct ownership of the /opt/rsa/am/radius/control-socket folder:
sudo chown root:root /opt/rsa/am/radius/control-socket
Related Articles
RSA Authentication Manager 8.x Backup Fails With Error 60Number of Views RSA Authentication Manager Restore from Microsoft Azure Snapshot or backup Failed 142Number of Views How to determine the size of a backup before creating one in RSA Identity Governance & Lifecycle 111Number of Views RSA Authentication Manager Backup Encryption 58Number of Views Authentication Manager: Backup failed to Windows Share (cifs) 177Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide