Custom URL is not rendering in the Review Instruction field and in the Review Email Body for RSA Via Lifecycle and Governance
2 years ago
Originally Published: 2016-05-27
Article Number
000050441
Applies To
RSA Product Set:  Via Lifecycle and Governance
RSA Product/Service Type: All
 
Issue
Whenever we enter the custom URL in the Review Instruction field and Review Email Body, the URL does not seem to render after saving the changes.  Steps to reproduce the issue are below:

Scenario 1: URL not rendering in Review Definition

  1. Add the custom URL in the Review Instructions field.
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  1. Click OK to save the settings.
  2. You can see the URL not rendering.
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  1. Edit the Review Definition and you will find the URL is not available:
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Scenario 2 : URL not Rendering in Review Email Body

1. Add the custom URL to Review Email Body:

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  1. Click on Finish.
  2. Edit the Email Template to validate the settings:
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  1. The hardcoded URL is not seen in the email body
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Cause
The reason for the URL not rendering is that we have not set the security setting in L&G to allow HTML markup under Admin > System > Security , as shown below:
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Resolution
To resolve the issue, the setting to allow the HTML to render the custom URL needs to be enabled.  To do this,
  1. Hover over Admin > System > Security.
  2. Under XSS/Scripting Security, make sure that Email Body (Templates, Review Emails) and Review Instructions is not set to No markup allowed.
  3. Set the option to Allow Sanitized HTML to see the URLs:
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