Emails from workflow approval/fulfillment nodes are not generated and sent due to error "Illegal hex characters in escape (%) pattern" in RSA Identity Governance & Lifecycle 7.0.2 P05
Originally Published: 2018-07-17
Last Modified: 2026-05-13
Article Number
Applies To
RSA Version/Condition: 7.0.2 P05
Issue
After upgrading to RSA Identity Governance and Lifecycle 7.0.2 P05, emails from the approval and fulfillment nodes do not get generated and sent for a few of the workflows due to the following error:
URLDecoder: Illegal hex characters in escape (%) pattern - For input string: "; "
You will find the error below in the aveksaServer.log:
ERROR (Worker_actionq#Script Queue - Normal#WPDS_279) [com.aveksa.server.workflow.scripts.nodes.SendEmailThread] Couldn't Send Email to due to: java.lang.IllegalArgumentException: URLDecoder: Illegal hex characters in escape (%) pattern - For input string: "; " at java.net.URLDecoder.decode(URLDecoder.java:192) at com.aveksa.server.workflow.scripts.nodes.SendEmailThread.getBody(SendEmailThread.java:109) at com.aveksa.server.workflow.scripts.nodes.SendEmailThread.sendEmail(SendEmailThread.java:146) at com.aveksa.server.workflow.scripts.nodes.SendEmailThread.sendEmail(SendEmailThread.java:66) at com.aveksa.server.workflow.scripts.nodes.SendEmailThread.run(SendEmailThread.java:62)
This error is similar to the error seen when the email node contains a percent (%) character as described in article 000036165 - After patching to RSA Identity Governance & Lifecycle 7.0.2 P03+, emails are not generated and sent due to the error 'Illegal hex characters in escape (%) pattern', but the cause is not similar.
Here, the issue is seen even if the email body does not contain any % characters.
Cause
Another cause for the email not being sent is due to a NullPointerException when either Workflow Variable or Object Attribute is added in the Send Email node.
Resolution
Workaround
- Save the workflow node which is not generating emails again, or
- Recreate the node after deleting the node which is having issue.
Related Articles
GUI shows initialization error "ORA-04063: package body "AVUSER.UTILITIES_PKG" has errors" after patching to 7.5.2 P07 in … 396Number of Views 8.5P4 linux webtier shows online-reinstall required 357Number of Views Error "Request Entity Too Large" when upgrading RSA Authentication Manager from versions (8.2 SP1 up to 8.4 P13) to 8.5 365Number of Views Unable to load form fields when using a form element of control type "Drop Down with Web Service" in RSA Identity Governan… 97Number of Views RSA Authentication Manager 8.x ntpq -p Command Fails with "Request Timed Out" When Checking NTP status 1.66KNumber of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?