Error when running RSA Via Lifecycle & Governance 7.0 customizeACM.sh: Could not find Aveksa ear
Originally Published: 2016-04-26
Last Modified: 2023-10-06
Article Number
Applies To
RSA Version/Condition: 7.0.0, 7.0.0 P01
Issue
acm-700:/home/oracle/deploy # ./customizeACM.sh -c
You have not specified an archive ear file to customize.
The current ear file deployed to Wildlfy is stored at:
/home/oracle/archive/aveksa_7.0.0_93958-2015-Aug-20-17.54.ear
Do you want to customize that archived ear file [yes/no]?yes
Could not find aveksa_7.0.0_93958-2015-Aug-20-17.54.ear. Please check /home/oracle/archive/ if using a relative path.Cause
Workaround
- Navigate to cd /home/oracle/deploy.
- Run the following command:
./customizeACM.sh -i /tmp/aveksa/staging,/tmp/repackaged_ear_dir
This will create a new .ear in the /home/oracle/archive directory with today's date in the filename, and update the wildfly_deployment.properties file with its name (CURRENTLY_DEPLOYED_ARCHIVE and INITIAL_ARCHIVE). Example output is as follows:
acm-700:/home/oracle/deploy # ./customizeACM.sh -i /tmp/aveksa/staging,/tmp/repackaged_ear_dir inflated: aveksa.war inflated: WEB-INF/classes/aveksa-version.properties source : /tmp/repackaged_ear_dir/aveksa.ear target : /home/oracle/archive/aveksa_7.0.0_93958-2016-Apr-26-0.31.ear
- Now run ./customizeACM.sh -c and it should find the new .ear file. If this is successful, delete the /tmp/archive backup directory and its contents. An example of a successful run of ./customizeACM.sh -c is:
acm-700:/home/oracle/deploy # ./customizeACM.sh -c
You have not specified an archive ear file to customize.
The current ear file deployed to Wildlfy is stored at:
/home/oracle/archive/aveksa_7.0.0_93958-2015-Aug-20-17.54.ear
Do you want to customize that archived ear file [yes/no]?yes
unzipping ear...
[unzip] Expanding: /home/oracle/archive/aveksa_7.0.0_93958-2015-Aug-20-17.54.ear into /tmp/customizeACM
Ready for customization. Please go to /tmp/customizeACM to continue modifications.Notes
Related Articles
Why does the restore of the backup fail when migrating from an earlier key manager appliance backup? 46Number of Views RSA Authentication Manager 8.1 replica attachment fails with error with migrated primary 257Number of Views AAoP scheduler issue on JBOSS 5.1 offlineTask throwing an Error due to main_table.xml 30Number of Views RSA Identity Governance and Lifecycle admin error email in email log view error link redirects to main screen instead of a… 15Number of Views Unable to install RSA Certificate Manager on a migrated nCipher Security World 26Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?