Failed to validate remote location error when configuring backups to Windows Shared Folder in RSA Authentication Manager 8.x
2 years ago
Originally Published: 2015-04-15
Article Number
000055977
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.x
Issue
"Failed to validate remote location" error when configuring backups from the Operations Console (Maintenance > Backup and Restore > Manage Backups) when selecting Windows Shared Folder as a backup location.

System log show the following error: 
15-04-15 11:37    ERROR    26113    Create backup via OC    Operations Console administrator “RSAAdmin” 
attempted to create a backup at “\\sample.com\RSA_Backup\201504151135.RSAbackup”    
Failure Unexcepted exception caught    RSAAdmin    UNEXPECTED_EXCEPTION    testAM81pri.kangnet.local    
10.10.10.1    10.10.10.2 .admin.impl.OCManageBackupImpl$1CreateBackupThread \\sample.com\Share\201504151135.RSAbackup



 
Cause
There might be multiple causes to such error message: 
  • Local security policy or group policy requires NTLMv2 on the network refusing LM and NTLMv1 (Note:   RSA Authentication Manager 8.1 SP1 patch 1 included NTLMv2 support).
  • DNS resolves the Windows server where hostname is used.
  • Directory has correct permissions.
Resolution

Multiple things can be tried to see what the issue is:

  1. Check if the remote location is pinging from the appliance. From the Operations Console select Administration > Network > Network Tools).
  2. Try mounting the remote share manually, by executing the following steps:
    1. SSH into Authentication Manager primary.
    2. Change to root using the command:
sudo su -
  1. Create a test directory under /opt/rsa/am/backup to see if the Remote Shared Folder can be mounted to it. 
mkdir /opt/rsa/am/backup/test
  1. Try mounting the Remote Shared Folder to the newly created directory.
mount.cifs <Remote_Share> /opt/rsa/am/backup/test -o user=<Share_User>,domain=<Name>
  1. Provide the remote share password when prompted.
  2. If the command in step 4 didn't work, please try with sec option as below for NTLMv2: 
mount.cifs //sample.com/Share /opt/rsa/am/backup/test -o user=<Share_User>,domain=<Name>,sec=ntlmssp
OR
mount.cifs //sample.com/Share /opt/rsa/am/backup/test -o user=<Share_User>,domain=<Name>, sec=ntlmsspi
  1. If the mount in step 2 worked, try to create a file on the mounted Remote Folder to check the permissions. 
    1. Create a file to validate the user has write permissions:
echo "test">/opt/rsa/am/backup/test/test.txt
  1. Validate test.txt file created in the Remote Location.
  • If step 1 fails, then there is a connection problem.
  • If step 2 fails, then there is a mount issue and a mount error will appear clearly.
  • Lastly, if step 3 fails, then the user used for mounting the remote folder does not have sufficient permissions. 

After identifying the issue, then it can be resolved much easier.