Generic REST Collector test fails with 'Unexpected response content type received. Expected content type is: application/json but received:{1}' in RSA Identity Governance & Lifecycle
Originally Published: 2020-06-10
Last Modified: 2022-06-20
Article Number
Applies To
RSA Version/Condition: 7.2.0
Issue
Unexpected response content type received. Expected content type is: application/json but received:{1}
Check logs for details.
Check logs for details.
The Request Headers in the collector definition are configured as follows:
The following error is logged to the aveksaServer.log file ($AVEKSA_HOME/wildfly/standalone/log/aveksaServer.log):
04/30/2020 17:08:43.611 ERROR (ApplyChangesPerformQueryThread-372) [com.aveksa.client.genericrest.postprocessor.impl.GenericRESTPostprocessorImpl] Unexpected response content type: { Expected: application/json, Received: , Response Content: {"d":{"results":[{"__metadata": ... ... 04/30/2020 17:08:43.613 ERROR (ApplyChangesPerformQueryThread-372) [com.aveksa.collector.generic.rest.adc.GenericRESTAccountDataReader] Error in Test Rest API: com.aveksa.client.genericrest.GenericRestException: UNEXPECTED_RESPONSE_CONTENT_TYPE application/json at com.aveksa.client.genericrest.GenericRestException.connectionError(GenericRestException.java:108)
Please refer to RSA Knowledge Base Article 000030327 -- Artifacts to gather in RSA Identity Governance & Lifecycle to find the location of the aveksaServer.log file for your specific deployment if you are on a WildFly cluster or a non-WildFly platform. The aveksaServer.log may also be downloaded from the RSA Identity Governance & Lifecycle user interface (Admin > System > Server Nodes tab > under Logs.)
Cause
An example of a datasource that returns a lowercase response header is SAP as seen when using a software development tool such as Postman to test the API:
Resolution
- RSA Identity Governance & Lifecycle 7.2.0 P02
- RSA Identity Governance & Lifecycle 7.2.1
Notes
Note that the "Unexpected response content type error" occurs whenever the error response does not match the expected type. This article only documents one such instance of this error. Unless all the symptoms match this article, you do not have this issue.
Related Articles
Java error "Received fatal alert: handshake_failure" when opening RSA enVision Event Explorer 101Number of Views LDAP search error - [LDAPsearch] referral received 31Number of Views Error "This field cannot exceed 4000 characters" is received when adding membership rule in a Role in RSA Identity Governa… 9Number of Views Users receiving emails for a deleted review result in RSA Via Lifecycle and Governance 52Number of Views Immediate Next Token Code (NTC) error received for some user logins in RSA Authentication Manager 8.x 532Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?