Getting a Request could not be handled error when trying to change the certificate store on RSA Via Lifecycle & Governance 6.9.1 from the UI
Originally Published: 2016-05-16
Last Modified: 2023-09-22
Article Number
Applies To
RSA Product/Service Type: Access Certification Manager
RSA Version/Condition: 6.9.1, 6.8.1
Platform: Any
Issue
04/12/2016 10:59:21.597 ERROR (http-0.0.0.0-8445-7) [com.aveksa.UI] com.aveksa.gui.pages.base.data.dialog.EditableDialogPageData.handleRequest(EditableDialogPageData.java:46) -
com.rsa.crypto.InvalidAlgorithmParameterException: Could not DER encode the public key. (No OID for this transformation.)
at com.rsa.cryptoj.o.bk.a(Unknown Source)
at com.rsa.cryptoj.o.bk.a(Unknown Source)
at com.rsa.cryptoj.o.bk.a(Unknown Source)
at com.rsa.cryptoj.o.fr.getEncoded(Unknown Source)
at com.aveksa.server.certificates.CertificateManager.createCertificate(CertificateManager.java:128)
at com.aveksa.server.certificates.CertificateManager.createCertificate(CertificateManager.java:100)
at com.aveksa.server.certificates.CertificateManager.createCertificate(CertificateManager.java:86)
at com.aveksa.server.certificates.CertificateManager.createCertificateOfAuthority(CertificateManager.java:294)
at com.aveksa.server.certificates.CertificateManager.createCertificateOfAuthority(CertificateManager.java:279)
at com.aveksa.server.certificates.CertificateManager.createCertificates(CertificateManager.java:228)
at com.aveksa.server.certificates.CertificateServiceProvider.createServerCAAndKeyStore(CertificateServiceProvider.java:112)
at com.aveksa.server.certificates.CertificateServiceProvider.createServerCAAndKeyStore(CertificateServiceProvider.java:107)
at com.aveksa.gui.pages.admin.system.security.certificate.ChangeCertificateStorePageData.handleSubmit(ChangeCertificateStorePageData.java:53)
at com.aveksa.gui.pages.base.data.dialog.EditableDialogPageData.handleRequest(EditableDialogPageData.java:45)
at com.aveksa.gui.pages.PageManager.forwardRequest(PageManager.java:559)
at com.aveksa.gui.pages.PageManager.handleRequest(PageManager.java:323)
at com.aveksa.gui.pages.PageManager.handleRequest(PageManager.java:254)
at com.aveksa.gui.core.MainManager.handleRequest(MainManager.java:176)
at com.aveksa.gui.core.MainManager.doGet(MainManager.java:125)
at com.aveksa.gui.core.MainManager.doPost(MainManager.java:411)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at com.aveksa.gui.core.filters.LoginFilter.doFilter(LoginFilter.java:67)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at com.aveksa.gui.util.security.XSSFilter.doFilter(XSSFilter.java:20)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:179)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:524)
at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:84)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:157)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:262)
at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:446)
at java.lang.Thread.run(Thread.java:701)Cause
Resolution
Related Articles
Getting an error when trying to update rule via RulesPerFI load sheet 6Number of Views Provisioning Form fails with 'An error occurred loading the fields for the form' error while running in RSA Governance & L… 77Number of Views RSA Prime Current Release Information 49Number of Views RSA Identity Governance and Lifecycle 7.0.1 P01 installation gets stuck at message of undeploying current ear and deployin… 173Number of Views Error: 'Web-tier host certificate creation failed' when trying to create a web tier package 302Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?