RSA Product/Service Type: Appliance and soft appliance
RSA Version/Condition: 6.x, 7.0.x
This article explains how to run segment advisor on RSA Identity Governance & Lifecycle 7.0.2 and earlier for RSA-supplied databases. If you have a non-RSA supplied database, please contact your Oracle DBA for assistance in running segment advisor.
If you are on RSA Identity Governance & Lifecycle 7.1.0 or above, please see the section entitled Database Segment Maintenance on page 32 of the RSA Identity Governance & Lifecycle Database Setup and Management Guide for V7.1.1 for instructions on running segment advisor. (Note: Even if you are on 7.1.0, use the 7.1.1 guide.)
Please see RSA Knowledge Base Article 000038168 -- How to manage database growth in RSA Identity Governance & Lifecycle for an explanation on when to use segment advisor
- Log into the RSA Identity Governance & Lifecycle Oracle database server.
- Download the attached segmentAdvisor.zip to /home/oracle.
- Create a temporary directory under /home/oracle and move segmentAdvisor.zip to the temporary directory.
cd /home/oracle mkdir tempSA mv segmentAdvisor.zip tempSA
- Go to the temporary directory
- Unzip the zip file. Inside is segmentAdvisor.txt and segmentAdvisor.sql
- Copy segmentAdvisor.txt to segmentAdvisor.sh
cd tempSA unzip segmentAdvisor.zip mv segmentAdvisor.txt segmentAdvisor.sh
- Before running segmentAdvisor.sh, read through the script files (segmentAdvisor.sh and segmentAdvisor.sql) to see what they do. The segmentAdvisor.sh file explains how to run the script for the entire database or one table at a time. It also provides instructions on how to reclaim the freed up space.
- Run segment advisor.
sh segmentAdvisor.sh
- Once the script completes, there will be a file called RESULTS.TXT. Use the below command to see the segment advisor results:
grep -i estimate -A1 -B3 RESULTS.TXT
- Review the results and follow the instructions in the segmentAdvisor.sh file to reclaim unused space.
NOTE: Reclaim space during slow periods when the database is being minimally used to avoid contention.
Related Articles
Report preview and/or generation fails with 'java.lang.NoClassDefFoundError: Could not initialize class sun.awt.X11Graphic… 149Number of Views Cannot access Security Console after patch installation failed and restored to earlier version. 29Number of Views How to address a customer request for Customer Support to perform RSA Web Threat Detection upgrade 18Number of Views Upgrade of RSA Identity Governance and Lifecycle from earlier versions to 7.0.2 fails during WildFly configuration phase. 249Number of Views RSA Announces the Availability of RSA Identity Management and Governance 6.9.1 Patch 131 7Number of Views
Trending Articles
Artifacts to gather in RSA Identity Governance & Lifecycle How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device How to Update the Root (Server) and Client Certificates in RSA Identity Governance & Lifecycle Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle How to Download and Reinstall the AFX Server Archive in RSA Governance & Lifecycle