Initialization Failure: Unable to register service HeartbeatService on Websphere 7 using RSA Identity Management and Governance
Originally Published: 2015-07-08
Last Modified: 2023-09-22
Article Number
Applies To
RSA Product/Service Type: Enterprise Software
Platform: WebSphere
Issue
"Unable to register service HeartbeatService. com.aveksa.server.runtime.ServerException: Error with Heartbeat provider"
veksaServer.log shows:
ERROR (server.startup : 3) [com.aveksa.server.message.MessagePublisher] Failure on publish of Message: AcmSystemMessage{messageType=SERVER_START, message='null', action='null', description='null', origin='Aveksa', custom_data=null}
ERROR (server.startup : 3) [com.aveksa.server.message.MessagePublisher] Exception: javax.jms.JMSException: CWSIA0067E: An exception was received during the call to the method JmsMsgProducerImpl.sendMessage (#4): com.ibm.ws.sib.processor.exceptions.SIMPLimitExceededException: CWSIP0251E: The destination acmMessageTopic on messaging engine Aveksa-wpBus is not available because the high limit 50,000 for the number of messages for this destination has already been reached..
ERROR (server.startup : 3) [com.aveksa.server.node.HeartbeatServiceProvider] Exception starting Heartbeat Provider
com.aveksa.server.message.MessengerServiceException: Failure on publish of Message
at com.aveksa.server.message.MessagePublisher.publishMessage(MessagePublisher.java:143)
at com.aveksa.server.node.HeartbeatServiceProvider.initializeHeartbeatProvider(HeartbeatServiceProvider.java:134)
at com.aveksa.server.node.HeartbeatServiceProvider.initialize(HeartbeatServiceProvider.java:72)
at com.aveksa.server.core.Container.registerService(Container.java:274)
at com.aveksa.server.core.Container.initialize(Container.java:83)
at com.aveksa.server.runtime.AveksaSystem.initialize(AveksaSystem.java:216)
at com.aveksa.init.Startup.init(Startup.java:41)
at com.aveksa.gui.core.ACMFramework.init(ACMFramework.java:74)
at com.aveksa.gui.core.ACMFramework.initInstance(ACMFramework.java:66)
at com.aveksa.init.InitServlet.init(InitServlet.java:42)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.init(ServletWrapper.java:358)
at com.ibm.ws.webcontainer.servlet.ServletWrapperImpl.init(ServletWrapperImpl.java:169)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.initialize(ServletWrapper.java:1809)
at com.ibm.wsspi.webcontainer.extension.WebExtensionProcessor.createServletWrapper(WebExtensionProcessor.java:98)
at com.ibm.ws.webcontainer.webapp.WebApp.initializeTargetMappings(WebApp.java:705)
at com.ibm.ws.webcontainer.webapp.WebApp.commonInitializationFinally(WebApp.java:436)
at com.ibm.ws.webcontainer.webapp.WebAppImpl.initialize(WebAppImpl.java:304)
at com.ibm.ws.webcontainer.webapp.WebGroupImpl.addWebApplication(WebGroupImpl.java:100)
at com.ibm.ws.webcontainer.VirtualHostImpl.addWebApplication(VirtualHostImpl.java:166)
at com.ibm.ws.webcontainer.WSWebContainer.addWebApp(WSWebContainer.java:732)
at com.ibm.ws.webcontainer.WSWebContainer.addWebApplication(WSWebContainer.java:617)
at com.ibm.ws.webcontainer.component.WebContainerImpl.install(WebContainerImpl.java:376)
at com.ibm.ws.webcontainer.component.WebContainerImpl.start(WebContainerImpl.java:668)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:1127)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.fireDeployedObjectStart(DeployedApplicationImpl.java:1319)
at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:610)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:944)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:740)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:2051)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:385)
at com.ibm.ws.runtime.component.CompositionUnitImpl.start(CompositionUnitImpl.java:123)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:328)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.access$300(CompositionUnitMgrImpl.java:113)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl$CUInitializer.run(CompositionUnitMgrImpl.java:895)
at com.ibm.wsspi.runtime.component.WsComponentImpl$_AsynchInitializer.run(WsComponentImpl.java:349)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1604)
Caused by:
javax.jms.JMSException: CWSIA0067E: An exception was received during the call to the method JmsMsgProducerImpl.sendMessage (#4): com.ibm.ws.sib.processor.exceptions.SIMPLimitExceededException: CWSIP0251E: The destination acmMessageTopic on messaging engine Aveksa-wpBus is not available because the high limit 50,000 for the number of messages for this destination has already been reached..
at com.ibm.ws.sib.api.jms.impl.JmsMsgProducerImpl.sendMessage(JmsMsgProducerImpl.java:1262)
at com.ibm.ws.sib.api.jms.impl.JmsMsgProducerImpl.send(JmsMsgProducerImpl.java:778)
at com.ibm.ws.sib.api.jms.impl.JmsTopicPublisherImpl.publish(JmsTopicPublisherImpl.java:83)
at com.aveksa.server.message.MessagePublisher.publishMessage(MessagePublisher.java:139)
... 35 more
Caused by:
com.ibm.ws.sib.processor.exceptions.SIMPLimitExceededException: CWSIP0251E: The destination acmMessageTopic on messaging engine Aveksa-wpBus is not available because the high limit 50,000 for the number of messages for this destination has already been reached.
at com.ibm.ws.sib.processor.impl.PubSubInputHandler.localPut(PubSubInputHandler.java:1293)
at com.ibm.ws.sib.processor.impl.PubSubInputHandler.internalHandleMessage(PubSubInputHandler.java:1056)
at com.ibm.ws.sib.processor.impl.PubSubInputHandler.handleProducerMessage(PubSubInputHandler.java:989)
at com.ibm.ws.sib.processor.impl.ProducerSessionImpl.send(ProducerSessionImpl.java:599)
at com.ibm.ws.sib.api.jms.impl.JmsMsgProducerImpl.sendMessage(JmsMsgProducerImpl.java:1209)
... 38 more
ERROR (server.startup : 3) [com.aveksa.server.core.Container] Unable to register service HeartbeatService.
com.aveksa.server.runtime.ServerException: Error with Heartbeat provider
at com.aveksa.server.node.HeartbeatServiceProvider.initializeHeartbeatProvider(HeartbeatServiceProvider.java:137)
at com.aveksa.server.node.HeartbeatServiceProvider.initialize(HeartbeatServiceProvider.java:72)
at com.aveksa.server.core.Container.registerService(Container.java:274)
at com.aveksa.server.core.Container.initialize(Container.java:83)
at com.aveksa.server.runtime.AveksaSystem.initialize(AveksaSystem.java:216)
at com.aveksa.init.Startup.init(Startup.java:41)
at com.aveksa.gui.core.ACMFramework.init(ACMFramework.java:74)
at com.aveksa.gui.core.ACMFramework.initInstance(ACMFramework.java:66)
at com.aveksa.init.InitServlet.init(InitServlet.java:42)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.init(ServletWrapper.java:358)
at com.ibm.ws.webcontainer.servlet.ServletWrapperImpl.init(ServletWrapperImpl.java:169)
at com.ibm.ws.webcontainer.servlet.ServletWrapper.initialize(ServletWrapper.java:1809)
at com.ibm.wsspi.webcontainer.extension.WebExtensionProcessor.createServletWrapper(WebExtensionProcessor.java:98)
at com.ibm.ws.webcontainer.webapp.WebApp.initializeTargetMappings(WebApp.java:705)
at com.ibm.ws.webcontainer.webapp.WebApp.commonInitializationFinally(WebApp.java:436)
at com.ibm.ws.webcontainer.webapp.WebAppImpl.initialize(WebAppImpl.java:304)
at com.ibm.ws.webcontainer.webapp.WebGroupImpl.addWebApplication(WebGroupImpl.java:100)
at com.ibm.ws.webcontainer.VirtualHostImpl.addWebApplication(VirtualHostImpl.java:166)
at com.ibm.ws.webcontainer.WSWebContainer.addWebApp(WSWebContainer.java:732)
at com.ibm.ws.webcontainer.WSWebContainer.addWebApplication(WSWebContainer.java:617)
at com.ibm.ws.webcontainer.component.WebContainerImpl.install(WebContainerImpl.java:376)
at com.ibm.ws.webcontainer.component.WebContainerImpl.start(WebContainerImpl.java:668)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:1127)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.fireDeployedObjectStart(DeployedApplicationImpl.java:1319)
at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:610)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:944)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:740)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:2051)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:385)
at com.ibm.ws.runtime.component.CompositionUnitImpl.start(CompositionUnitImpl.java:123)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.start(CompositionUnitMgrImpl.java:328)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl.access$300(CompositionUnitMgrImpl.java:113)
at com.ibm.ws.runtime.component.CompositionUnitMgrImpl$CUInitializer.run(CompositionUnitMgrImpl.java:895)
at com.ibm.wsspi.runtime.component.WsComponentImpl$_AsynchInitializer.run(WsComponentImpl.java:349)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1604)
Caused by:
com.aveksa.server.message.MessengerServiceException: Failure on publish of Message
at com.aveksa.server.message.MessagePublisher.publishMessage(MessagePublisher.java:143)
at com.aveksa.server.node.HeartbeatServiceProvider.initializeHeartbeatProvider(HeartbeatServiceProvider.java:134)
... 34 more
Caused by:
javax.jms.JMSException: CWSIA0067E: An exception was received during the call to the method JmsMsgProducerImpl.sendMessage (#4): com.ibm.ws.sib.processor.exceptions.SIMPLimitExceededException: CWSIP0251E: The destination acmMessageTopic on messaging engine Aveksa-wpBus is not available because the high limit 50,000 for the number of messages for this destination has already been reached..
at com.ibm.ws.sib.api.jms.impl.JmsMsgProducerImpl.sendMessage(JmsMsgProducerImpl.java:1262)
at com.ibm.ws.sib.api.jms.impl.JmsMsgProducerImpl.send(JmsMsgProducerImpl.java:778)
at com.ibm.ws.sib.api.jms.impl.JmsTopicPublisherImpl.publish(JmsTopicPublisherImpl.java:83)
at com.aveksa.server.message.MessagePublisher.publishMessage(MessagePublisher.java:139)
... 35 more
Caused by:
com.ibm.ws.sib.processor.exceptions.SIMPLimitExceededException: CWSIP0251E: The destination acmMessageTopic on messaging engine Aveksa-wpBus is not available because the high limit 50,000 for the number of messages for this destination has already been reached.
at com.ibm.ws.sib.processor.impl.PubSubInputHandler.localPut(PubSubInputHandler.java:1293)
at com.ibm.ws.sib.processor.impl.PubSubInputHandler.internalHandleMessage(PubSubInputHandler.java:1056)
at com.ibm.ws.sib.processor.impl.PubSubInputHandler.handleProducerMessage(PubSubInputHandler.java:989)
at com.ibm.ws.sib.processor.impl.ProducerSessionImpl.send(ProducerSessionImpl.java:599)
at com.ibm.ws.sib.api.jms.impl.JmsMsgProducerImpl.sendMessage(JmsMsgProducerImpl.java:1209)
... 38 more
INFO (server.startup : 3) [com.aveksa.server.runtime.AveksaSystem] ******************** Waiting For Local Agent ********************
INFO (server.startup : 3) [com.aveksa.server.runtime.AveksaSystem] ******************** Agent started ********************
INFO (server.startup : 3) [com.aveksa.server.runtime.AveksaSystem] ******************** Starting Execution Context Workers ********************
INFO (server.startup : 3) [com.aveksa.server.runtime.AveksaSystem] ******************** Aveksa System Initialization End ********************
FATAL (server.startup : 3) [com.aveksa.server.runtime.AveksaSystem]
****************************************
Initialization has failed!
Unable to register service HeartbeatService. com.aveksa.server.runtime.ServerException: Error with Heartbeat provider
****************************************
The following errors are also found earlier in the log:
ERROR (Exec Context Consumer#0) [com.aveksa.server.message.MessagePublisher] Failure on publish of Message: AcmSystemMessage{messageType=EXECUTION_RESULT, message='Completed', action='null', description='null', origin='Aveksa', custom_data=1731246}
ERROR (Exec Context Consumer#0) [com.aveksa.server.message.MessagePublisher] Exception: javax.jms.JMSException: CWSIA0067E: An exception was received during the call to the method JmsMsgProducerImpl.sendMessage (#4): com.ibm.ws.sib.processor.exceptions.SIMPLimitExceededException: CWSIP0251E: The destination acmMessageTopic on messaging engine Aveksa-wpBus is not available because the high limit 50,000 for the number of messages for this destination has already been reached..
06/19/2015 06:25:01.701 ERROR (Exec Context Consumer#0) [com.aveksa.server.xfw.ExecutionWorkerThread] run
com.aveksa.server.message.MessengerServiceException: Failure on publish of Message
at com.aveksa.server.message.MessagePublisher.publishMessage(MessagePublisher.java:143)
at com.aveksa.server.xfw.ExecutionWorkerThread.runContext(ExecutionWorkerThread.java:94)
at com.aveksa.server.xfw.ExecutionWorkerThread.run(ExecutionWorkerThread.java:53)
at java.lang.Thread.run(Thread.java:736)
Caused by:
javax.jms.JMSException: CWSIA0067E: An exception was received during the call to the method JmsMsgProducerImpl.sendMessage (#4): com.ibm.ws.sib.processor.exceptions.SIMPLimitExceededException: CWSIP0251E: The destination acmMessageTopic on messaging engine Aveksa-wpBus is not available because the high limit 50,000 for the number of messages for this destination has already been reached..
at com.ibm.ws.sib.api.jms.impl.JmsMsgProducerImpl.sendMessage(JmsMsgProducerImpl.java:1262)
at com.ibm.ws.sib.api.jms.impl.JmsMsgProducerImpl.send(JmsMsgProducerImpl.java:778)
at com.ibm.ws.sib.api.jms.impl.JmsTopicPublisherImpl.publish(JmsTopicPublisherImpl.java:83)
at com.aveksa.server.message.MessagePublisher.publishMessage(MessagePublisher.java:139)
... 3 more
Caused by:
com.ibm.ws.sib.processor.exceptions.SIMPLimitExceededException: CWSIP0251E: The destination acmMessageTopic on messaging engine Aveksa-wpBus is not available because the high limit 50,000 for the number of messages for this destination has already been reached.
at com.ibm.ws.sib.processor.impl.PubSubInputHandler.localPut(PubSubInputHandler.java:1293)
at com.ibm.ws.sib.processor.impl.PubSubInputHandler.internalHandleMessage(PubSubInputHandler.java:1056)
at com.ibm.ws.sib.processor.impl.PubSubInputHandler.handleProducerMessage(PubSubInputHandler.java:989)
at com.ibm.ws.sib.processor.impl.ProducerSessionImpl.send(ProducerSessionImpl.java:599)
at com.ibm.ws.sib.api.jms.impl.JmsMsgProducerImpl.sendMessage(JmsMsgProducerImpl.java:1209)
... 6 more
Cause
Resolution
Workaround
If using data store, clean up the JMS queue and restart the application.
Please contact IBM support for helping performing the steps above.
Related Articles
Unable to register the SecurID app with the Cloud Authentication Service using the Prime Self-Service Portal 101Number of Views Initialization error "Unable to register service ReviewService" and "Unable to start local agent" in RSA Identity Governan… 374Number of Views Unable to register an RSA SecurID Access SSO application in the Cloud Administration Console 42Number of Views Limiting users to one token per user ID in RSA Authentication Manager 8.x 135Number of Views How to register a FIDO security key as an MFA authenticator to use when accessing RSA customer or partner applications 144Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?