Initialization error "Unable to register service ReviewService" and "Unable to start local agent" in RSA Identity Governance and Lifecycle 7.x
Originally Published: 2017-01-25
Last Modified: 2023-09-25
Article Number
Applies To
RSA Version/Condition: 7.0.0+, 7.0.1
Issue
The RSA Identity Governance & Lifecycle application User Interface (UI) will not come up after a restart. The initialization error as shown here is displayed:
Initialization Status
Initialization operations completed with errors. Please resolve the problems(s) before the application server can accept requests.
Unable to register service ReviewService.com.aveksa.server.runtime.ServerException: java.lang.NullPointerException
Unable to start local agent.java.lang.Exception: Local Agent could not be deployed in the system.

Initialization operations completed with errors. Please resolve the problems(s) before the application server can accept requests.
Unable to register service ReviewService.com.aveksa.server.runtime.ServerException: java.lang.NullPointerException
Unable to start local agent.java.lang.Exception: Local Agent could not be deployed in the system.
The $AVEKSA_WAR_DIR/log/aveksaServer.log shows the following errors:
12/12/2016 18:37:42.294 ERROR (MSC service thread 1-3) [com.aveksa.server.core.Container] Unable to register service ReviewService.
com.aveksa.server.runtime.ServerException: java.lang.NullPointerException
at com.aveksa.server.review.ReviewServiceProvider.initialize(ReviewServiceProvider.java:208)
at com.aveksa.server.core.Container.registerService(Container.java:289)
at com.aveksa.server.core.Container.initialize(Container.java:83)
at com.aveksa.server.runtime.AveksaSystem.doStartupOperations(AveksaSystem.java:329)
at com.aveksa.server.runtime.AveksaSystem.initialize(AveksaSystem.java:305)
......
12/12/2016 18:37:46.958 ERROR (MSC service thread 1-3) [com.aveksa.server.runtime.AveksaSystem] Unable to start local agent.
java.lang.Exception: Local Agent could not deployed in the system.
at com.aveksa.server.core.Container.startLocalAgent(Container.java:376)
at com.aveksa.server.core.Container.startLocalAgent(Container.java:334)
at com.aveksa.server.runtime.AveksaSystem.doStartupOperations(AveksaSystem.java:383)
.....
[com.aveksa.server.authorization.XXAuthorizationServiceProvider] Initializing of XXAuthorizationServiceProvider Context
12/12/2016 18:37:47.527 ERROR (MSC service thread 1-3) [com.aveksa.server.authorization.XXAuthorizationServiceProvider] loading security contexts
java.lang.NullPointerException
at com.aveksa.server.authorization.XXAuthorizationServiceProvider.init(XXAuthorizationServiceProvider.java:267)
at com.aveksa.server.runtime.AveksaSystem.doStartupForNonStandaloneServer(AveksaSystem.java:421)
at com.aveksa.server.runtime.AveksaSystem.initialize(AveksaSystem.java:307)Cause
Resolution
Workaround
Related Articles
Unable to register the SecurID app with the Cloud Authentication Service using the Prime Self-Service Portal 101Number of Views Unable to register an RSA SecurID Access SSO application in the Cloud Administration Console 42Number of Views Initialization error "Unable to register plugin InformationCommandHandler" using Websphere 9 in RSA Identity Governance an… 9Number of Views Error message when attempting to register on the RSA Community (The Salesforce record provisioning for the user failed wit… 18Number of Views RSA Identity Governance & Lifecycle startup fails with "Unable to start service WorkflowService. java.lang.IndexOutOfBound… 128Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?