RSA Identity Governance and Lifecycle 7.0.2 displays error communicating with server when saving workflows having more than 25 nodes
Originally Published: 2017-06-16
Last Modified: 2023-10-06
Article Number
Applies To
RSA Version/Condition: 7.0.2, 7.0.2 P01, 7.0.2 P01HF01
Issue
- Saving a workflow that contains more than 25 nodes, or
- Switching between nodes in a workflow that has more than 25 nodes.
2017-06-08 08:16:33,975 ERROR [org.grails.web.errors.GrailsExceptionResolver] (default task-23) IOException occurred when processing
request: [PUT] /aveksaWFArchitect/processes/checkNodeSyntax/ UT000020: Connection terminated as request was larger than 128000. Stacktrace follows:: java.io.IOException: UT000020:Cause
Resolution
Workaround
- Download the aveksaWFArchitect.ear from /tmp/aveksa/staging directory or from the patch directory if you have installed 7.0.2 into a new directory. By using a new directory, the original ear will be left untouched (in effect, backed-up.)
$ cd /home/oracle $ mkdir unpack $ cp /home/oracle/Aveksa_7.0.2_P01HF01/aveksaWFArchitect.ear/aveksaWFArchitect.ear unpack $ cd unpack $ mkdir ear $ cd ear $ jar xvf ../aveksaWFArchitect.ear $ mkdir war $ cd war $ jar xvf ../aveksaWFArchitect.war $ vi WEB-INF/classes/application.yml
- Add the following content in the application.yml file, as shown in the screen shot below:
upload:
maxFileSize: 2000000
maxRequestSize: 2000000
$ cd .. $ jar cvf aveksaWFArchitect.war -C war . $ rm -Rf war $ cd .. $ jar cvf aveksaWFArchitect.ear -C ear . $ rm -Rf ear
- Deploy the new aveksaWFArchitecitect.ear:
$ /home/oracle/wildfly/bin/jboss-cli.sh -c --command="deploy /home/oracle/unpack/aveksaWFArchitect.ear --force"
- Restart ACM:
acm restart
- Login and modify the workflow(s) which had the issue.
- You will see a syntax warning, which is the expected behavior. Click Yes.
- The workflow should save successfully.
Notes
Related Articles
RSA Identity Governance and Lifecycle aveksaServer.log file filled with warning "Logging event having message 'Logging eve… 95Number of Views Completion Code Required error message occurs when saving a workflow in RSA Identity Governance & Lifecycle 18Number of Views In RSA Identity Governance & Lifecycle, a SQL exception error in the UI is encountered when saving Delay node on a Workflow 122Number of Views Review Results are not generated for users having no last names in RSA Identity Governance & Lifecycle 30Number of Views Unable to Save changes to Account Collector in RSA Identity Governance & Lifecycle 15Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?