RSA VIA L&G / IMG / Aveksa - AFX fails to start times out and this error is in the logs A WebGroup/Virtual Host to handle /aveksa/afx/initialization has not been defined
Originally Published: 2015-08-19
Last Modified: 2023-09-25
Article Number
Applies To
RSA Version/Condition: AFX implementations
Platform: Enterprise Software
O/S Version: Applies to all supported OS configurations for Websphere
Issue
The following specific error is present in the mule.AFX-INIT.log under <afx user>/AFX/mule/logs
[ERROR] org.mule.module.launcher.application.DefaultMuleApplication:365 - null java.lang.Exception: HTTP response error. Response code=404 : Reason= <H1>SRVE0255E: A WebGroup/Virtual Host to handle /aveksa/afx/initialization has not been defined.</H1> <BR><H3>SRVE0255E: A WebGroup/Virtual Host to handle img.vcloud.local:8444 has not been defined.</H3> <BR><I>IBM WebSphere Application Server</I>
Cause
Resolution
In the following example port 8444 is demonstrated as the Agent / AFX return port, if using a different port follow the same steps just replace 8444 with your port.
Expand the Environment category on the left pane
Click on / Select Virtual Hosts
In the right pane Click default_host
On the far right click the hyperlink Host Aliases
Check to see if Port 8444 is defined in this list, if yes, make sure it is mapped to *, If not click the New button
For Host Name enter *
For Port enter 8444
Click the Apply button
Click the Save directly to the master configuration. hyperlink at the top of the screen
After making this change, restart the server instance that is hosting the IMG application for this change to be applied.
Then restart the AFX server and it will have a virtual host configured to accept the connection.
Related Articles
Allowing a non-administrative user to see the monitoring screen IMG: Aveksa Monitoring page 16Number of Views Revert Changes calling out of the box Manual Activities workflow instead of the processing workflow used to fulfill the ch… 52Number of Views RSA SecurID Software Token 2.4 for iOS Administrator's Guide 60Number of Views RSA Announces the April 2020 Release of RSA SecurID Access 8Number of Views Introducing RSA Assistant: AI-Powered Support in RSA Community 10Number of Views
Trending Articles
Artifacts to gather in RSA Identity Governance & Lifecycle How to Update the Root (Server) and Client Certificates in RSA Identity Governance & Lifecycle How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle How to Download and Reinstall the AFX Server Archive in RSA Governance & Lifecycle
Don't see what you're looking for?