Risk Data Processing run fails in RSA Governance & Lifecycle
Last Modified: 2024-01-16
Article Number
Applies To
- RSA Identity Governance & Lifecycle 8.0
Issue
Errors "ORA-12008: error in materialized view or zonemap refresh path" and "ORA-01555: snapshot too old" are found in the aveksaServer.log:
Caused by: com.aveksa.server.db.PersistenceException: java.sql.SQLException: ORA-12008: error in materialized view or zonemap refresh path ORA-06512: at "SYS.DBMS_SNAPSHOT_KKXRCA", line 3020 ORA-06512: at "SYS.DBMS_SNAPSHOT_KKXRCA", line 2432 ORA-01555: snapshot too old: rollback segment number 1 with name "_SYSSMU1_1977979743$" too small ORA-06512: at "SYS.DBMS_SNAPSHOT_KKXRCA", line 88 ORA-06512: at "SYS.DBMS_SNAPSHOT_KKXRCA", line 253 ORA-06512: at "SYS.DBMS_SNAPSHOT_KKXRCA", line 2413 ORA-06512: at "SYS.DBMS_SNAPSHOT_KKXRCA", line 2976 ORA-06512: at "SYS.DBMS_SNAPSHOT_KKXRCA", line 3263 ORA-06512: at "SYS.DBMS_SNAPSHOT_KKXRCA", line 3295 ORA-06512: at "SYS.DBMS_SNAPSHOT", line 16 ORA-06512: at "AVUSER.DOF_RISK", line 3253 ORA-06512: at line 1 at com.aveksa.server.db.persistence.PersistenceServiceProvider.runStoredProcedure(PersistenceServiceProvider.java:1461) ~[server.jar:?] at com.aveksa.server.db.persistence.PersistenceServiceProvider.runStoredProcedure(PersistenceServiceProvider.java:1393) ~[server.jar:?] at com.aveksa.server.db.PersistenceManager.runStoredProcedure(PersistenceManager.java:196) ~[server.jar:?] at com.aveksa.server.xfw.RiskDataProcessTaskExecutor.executeTask(RiskDataProcessTaskExecutor.java:43) ~[server.jar:?] ... 3 more
Cause
Resolution
- RSA Governance & Lifecycle 8.0 P01
Workaround
Notes
- Risk Data Processing in RSA Governance & Lifecycle spots the trends and risks that are aligned with business needs using a configurable Risk Engine. It runs risk calculations, aggregates results over an in-memory grid and the software quickly handles complex calculations. It stores large volumes of results so you can investigate risk information using on-demand hierarchies in near-real time.
- Materialized Views: Some of the Materialized Views in Oracle database used by the Risk module in RSA Governance & Lifecycle may show up in an invalid state. Materialized Views are views that auto-update once the source tables updates, and they are cached (as opposed to normal views which don't). Materialized Views are much faster, and cause hugely positive memory impact on the database. The reason is that refreshing the Materialized Views is the last step in the Risk Processing run, therefore this issue renders them invalid. RSA Governance & Lifecycle uses "ON DEMAND" refresh type so the Materialized Views that may be showing in an invalid state, will be refreshed (and turn to normal state) once the Risk Module is executed.
Related Articles
ASR fails to generate with 'ORA-31011: XML parsing failed' and 'LPX-00225: end-element tag "ROWSET" does not match start-e… 69Number of Views Diagnostics and System Data Gathering Feature in RSA Identity Governance & Lifecycle 101Number of Views SA: puppet agent -t shows rabbitmq permission issues post upgrade or installation of packages. 36Number of Views RSA Identity Governance and Lifecycle - 702 Migration fails with ORA-01720: grant option does not exist for 'SYS.DUAL' 139Number of Views Collector run fails during the data collection task with an ORA-12899 or ORA-01722 error in RSA Governance & Lifecycle 577Number of Views
Trending Articles
Artifacts to gather in RSA Identity Governance & Lifecycle How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device How to Update the Root (Server) and Client Certificates in RSA Identity Governance & Lifecycle Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle RSA MFA Agent for UNIX Platform Support Matrix
Don't see what you're looking for?