SA: UI fails to load due to wrong version of Java being installed
3 years ago
Originally Published: 2016-02-09
Article Number
000063088
Applies To
RSA Security Analytics 10.4.x, 10.5.x
Issue
If sa.repo is enabled by mistake, it might lead to a different Java version to be installed  due to which the SA UI fails to load

# netstat -anp | grep 443 does show that the SA server is listening on port 443 but the UI is not accessible
Cause
This happens when a wrong version of Java is installed which can be due to sa.repo being enabled

sa.log will show errors as follows:
2016-01-22 08:33:12,028 [org.springframework.scheduling.quartz.SchedulerFactoryBean#0_Worker-1] ERROR com.rsa.netwitness.cms.impl.CmsClientImpl - peer not authenticated
javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated

2016-01-22 08:33:12,034 [org.springframework.scheduling.quartz.SchedulerFactoryBean#0_Worker-1] ERROR com.rsa.smc.sa.live.job.quartz.SubscriptionJob - Error looking up resource: Outbound Network Traffic


Check the existing Java RPM with the following command and make a note

# rpm -qa | grep java


 
Resolution
- Download the Java RPM from the following location:
http://vault.centos.org/6.6/updates/x86_64/Packages/java-1.7.0-openjdk-1.7.0.85-2.6.1.3.el6_6.x86_64.rpm
- Once downloaded, SCP it to the SA server
- Stop the following services on the SA server
# stop jettysrv
# service rsa-im stop
# service rsa-sms stop

- Install the java RPM with the following command
# rpm -ivh --force java-1.7.0-openjdk-1.7.0.85-2.6.1.3.el6_6.x86_64.rpm
- Uninstall the existing RPM
# rpm -e <existing Java RPM name>
- Once uninstalled, start the services
# start jettysrv
# service rsa-im start
# service rsa-sms start