SELinux Does Not Allow Apache and RSA Agent to Run
Originally Published: 2015-08-11
Last Modified: 2023-10-06
Article Number
Applies To
Apache Webserver
Issue
CONGRATULATIONS!
RSA Access Manager Agent 5.0 for Apache has been successfully installed to /opt
========================================================================
Next Steps
-----------------
- Restart the webserver
PRESS <ENTER> TO EXIT THE INSTALLER:
[root@************ axm]# service httpd restart
Stopping httpd: [FAILED]
Starting httpd: httpd: Syntax error on line 1011 of /etc/httpd/conf/httpd.conf: Syntax error on line 9 of /opt/rsa-axm/agent-50-apache/webservers/********/conf/ct-httpd.conf: Cannot load /opt/rsa-axm/agent-50-apache/lib/libct_apache22_agent.so into server: /opt/rsa-axm/agent-50-apache/lib/libct_apache22_agent.so: failed to map segment from shared object: Permission denied
Notes
We have not verified/qualified our agent with SElinux enabled or disabled. The above solution is just for information not sure whether it addresses the issue.
Related Articles
Configure Silent Collection for a Risk-Based Authentication Policy 6Number of Views The WorkDay Collector Configure Extensible Attributes Xpath Value text box does not allow quotes in RSA Identity Governanc… 27Number of Views RSA Via Lifecycle and Governance Salesforce Account Data Collector does not allow configuration without a "Security Token" 94Number of Views Lockout Policy 90Number of Views Self-Service Troubleshooting Policy 28Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device How to test RSA Identity Router (IDR) Secure Connector connectivity to the RSA ID Plus Cloud Access Service RSA SecurID Software Token for Microsoft Windows shows blank screen when asked to select a device where the token will be … RSA Governance & Lifecycle Generic Database Collector Guide RSA Authentication Manager 8.7 SP2 Administrator's Guide
Don't see what you're looking for?