DN Root of data store has a space e.g.: 'o=my company c=us'
Originally Published: 2004-01-06
Last Modified: 2023-10-06
Article Number
Applies To
Sun Solaris
Issue
Error: "Too may arguments" while running configtool.sh
Cause
Resolution
1. Edit configtool.sh's ADDLDAP line to the following which has quotes around each argument:
./configtool.sh ADDLDAP "$LDAP_CONFIG_NAME" "$TYPE" "$LDAP_SERVER" "$PORT" "$SECUREPORT" "$DN_ROOT" "$USER_BRANCH" "$RSA_BRANCH" "$LDAP_ACCOUNT_DN" "$PASSWORD" "$CONFIRM"
. Edit configtool.sh and change the following line:
$JAVA_HOME/bin/java $VM_OPTIONS $RSA_OPTIONS com.rsa.csf.techservice.datastore.configuration.ConfigTool $*
to the following:
$JAVA_HOME/bin/java $VM_OPTIONS $RSA_OPTIONS com.rsa.csf.techservice.datastore.configuration.ConfigTool $@
NOTE: Changing "$*" to "$@" tells configtool to pass the arguments as quoted strings.
3. Rerun the configuredatastore.sh script
Related Articles
RSA Governance & Lifecycle Integration: Microsoft Office 365 O365 Summary 79Number of Views Installation fails on Linux due to missing O/S libraries 68Number of Views RSA SecurID Access O365 WS-Fed Authentication Fails Intermittently 117Number of Views O365 WS-Fed authentication fails with RSA SecurID Access 116Number of Views When signing a SHA256 CA off a SHA1 Root CA it does not have a SHA256 signature algorithm in RCM 153Number of Views
Trending Articles
Artifacts to gather in RSA Identity Governance & Lifecycle How to Update the Root (Server) and Client Certificates in RSA Identity Governance & Lifecycle How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle How to Download and Reinstall the AFX Server Archive in RSA Governance & Lifecycle
Don't see what you're looking for?