Installation fails on Linux due to missing O/S libraries
Originally Published: 2014-02-13
Last Modified: 2023-10-06
Article Number
Applies To
RSA Registration Manager 6.9
Cent OS 6.4 (64-bit)
Linux
Issue
[root@test-box RSA_CM]# ./INSTALL
...
...
Installing on a local filesystem...
./INSTALL: ./xudad: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
Configuration of installation directory server failed.
Terminating installation prematurely.
[root@test-box RSA_CM]# ./INSTALL
...
...
Installing on a local filesystem...
./xudad: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
Configuration of installation directory server failed.
Terminating installation prematurely.
[root@test-box RSA_CM]# ./INSTALL
...
...
./httpsd: error while loading shared libraries: libgdbm.so.2: cannot open shared object file: No such file or directory
Failed to launch installation web server
Terminating installation prematurely.
Cause
/lib/ld-linux.so.2: bad ELF interpreter: No such file or directory ==> glibc.i686 must be installed
libstdc++.so.6: cannot open shared object file: No such file or directory ==> libstdc++ and/or libstdc++-4.4.7-3.el6.i686 (or latest) must be installed
libgdbm.so.2: cannot open shared object file: No such file or directory ==> gdbm.i386 must be installed
Resolution
yum -y install glibc.i686
yum whatprovides libstdc++.so.6 ==> a response to this command will show which GNU C++ Library, such as libstdc++-4.4.7-3.el6.i686, needs to be installed
yum -y install libstdc++
yum -y install libstdc++-4.4.7-3.el6.i686
yum -y install gdbm.i386
Workaround
Notes
Error: Protected multilib versions: libstdc++-4.4.7-3.el6.i686 != libstdc++-4.4.6-3.el6.x86_64
This can happen because multilib is the term Red Hat (and CentOS of course) use for a 64-bit system which also has 32-bit libraries. The packaging system won't install a newer version of the 32-bit library than the 64-bit version. In this scenario, run the following command:
[root@test-box RSA_CM]# yum update -y
Related Articles
RSA Governance & Lifecycle Integration: Microsoft Office 365 O365 Summary 79Number of Views DN Root of data store has a space e.g.: 'o=my company c=us' 11Number of Views RSA SecurID Access O365 WS-Fed Authentication Fails Intermittently 117Number of Views O365 WS-Fed authentication fails with RSA SecurID Access 116Number of Views How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device 982Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?