setsyncint fails to read all the tokens in the database in RSA ACE/Server 5.1 and 5.2
Originally Published: 2004-06-15
Last Modified: 2023-09-25
Article Number
000057241
Applies To
RSA ACE/Server 5.2
RSA ACE/Server 5.1 (no longer supported as of 7-14-2006)
UNIX (AIX, HP-UX, Solaris)
Issue
setsyncint fails to read all the tokens in the database in RSA ACE/Server 5.1 and 5.2
Error "SETSYNC fatal error (Error decrypting token security block) 2"
Cause
Database inconsistencies cause the setsyncint utility to stop processing token information. This typically occurs at the start of a new batch of tokens.
Resolution
To correct this issue, stop all services and run sdcompress -s, ensuring it runs to completion. Then restart the services and run setsyncint again; this time it should be able to read all tokens in the database.