Error: 'The user is not enabled for authentication. Please contact your administrator.' in RSA Mobile
2 years ago
Originally Published: 2004-07-07
Article Number
000060839
Applies To
RSA Mobile
RSA Mobile 1.5
RSA Mobile 1.5 Authentication Server
Microsoft Windows 2000
Issue
Error: "The user is not enabled for authentication. Please contact your administrator." in RSA Mobile
Cause
If all RSA Mobile administrators get locked out (e.g. due to errors when testing the system), there exists a 'Catch 22' situation where you need to log in as an administrator to re-enable the administration account(s)
Resolution
The problem is resolved by remembering that all the data is stored inside a directory server (currently supported systems are Sun ONE, Microsoft Active Directory, and CA eTrust). This means that standard LDAP administration tools can be used to modify the information. An example of a common tool used is LDAP Browser found at http://www.iit.edu/~gawojar/ldap/. NOTE: Do not try to use the Microsoft "Active Directory Users and Computers" utility; this will enable you to see the required objects but not modify them, since the tool is dedicated to management of Windows 2000 objects.

In the following steps, an example is shown where the BaseDN is "dc=acme,dc=com"

1. Connect with your LDAP administration tool

2. Browse to ou=rsausers,ou=rsa,dc=acme,dc=com . This will present you with a list of objects with names like "rsauuid=A345439FGETFKJF89348590345". The first few in the list are the ones you are interested in - for example, the very first was the first administrator you added using "ADDFULLADMIN".

3. Examine the object and you will find a property called "rsaenabled"

4. Change the value of the property to read "true"

5. Save your changes

You should now find that you have re-enabled your administrative account. At this point, it is worth remembering the advantages of configuring more than one administrative account as outlined on page 40 of the RSA Mobile 1.5 Planning, Deployment, and Installation Guide.

For more information, see the solution regarding How to reset the Bad Password Count on RSA Mobile.