Error: 'Sd_ApiInit Error Failed to Connect to the serv DB /path/ace/data/sdserv'
Originally Published: 2001-08-17
Last Modified: 2023-10-06
Article Number
Applies To
RSA Authentication Manager 6.0
Microsoft Windows 2000
Microsoft Windows Server 2003
RSA ACE/Server Administration API
test.tcl
Sample program
Issue
Sample TCL script does not run on RSA ACE/Server
Error: "Can't read "env(VAR_ACE)": no such element in array" when making Sd_ApiInit call
Cause
The environment variable VAR_ACE is not set
Resolution
For Sd_ApiInit, you don't have to specify the exact location of the database. You can call it using the following syntax:
Sd_ApiInit "" "" 1
This will use the default location of the ACE/Server databases.
NOTE: Remember that the ACE/Server brokers must be running. In situations where the brokers are not running, you would use the Sd_ApiInitSingle call and, as the name suggests, must connect in single-user mode.
In the example of getting this error running test.tcl, simply set a variable called VAR_ACE before running TCL, for example
C:\ace\utils\tcl\BIN>set VAR_ACE=c:\ace\data
C:\ace\utils\tcl\BIN>tcl-sd
% source test.tcl
Connected User: aceadmin on Host:ace1.rsa.net
ace1.rsa.net
dc1.rsa.net
webserver.rsa.net
C:\ace\utils\tcl\BIN>
Related Articles
RSA Identity Governance and Lifecycle7.0.2 installation with remote database fails with "Invalid Username/Password" in the… 210Number of Views Test Authentication with RSA MFA Agent for macOS (Portuguese) 6Number of Views Troubleshooting Setpin program in RSA ACE/Server 8Number of Views Windows Error 10061 30Number of Views Detailed report of memory utilization on Linux for RSA Authentication Manager 8.x 416Number of Views
Trending Articles
Artifacts to gather in RSA Identity Governance & Lifecycle How to Update the Root (Server) and Client Certificates in RSA Identity Governance & Lifecycle How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Troubleshooting AFX Connector issues in RSA Identity Governance & Lifecycle How to Download and Reinstall the AFX Server Archive in RSA Governance & Lifecycle
Don't see what you're looking for?