RCM API unable to connect to the RCM to get certificate information
2 years ago
Originally Published: 2009-08-07
Article Number
000048796
Applies To
RSA Certificate Manager 6.8
Microsoft Windows Server 2003 SP2
Issue
RCM API unable to connect to the RCM to get certificate information

trying to retrieve certificate information from RCM using RCM API. The program runs fine on development RCM but failed to return information when running against our production RCM.


RCM API: XudaLDAPSearchFilter, etc.
Error: XrcXUDAUNABLE


Using API to query RCM over port 636 using SSL
Cause
Ports used by Keon Certificate Authority API blocked in the firewall
Resolution
Moved program to the production RCM and it worked. Issue was due to firewall blocking port 636 to production RCM.

See solution Whichports must be opened in a firewall forKeon Certificate Authority API to work correctly? for ports to open with firewall.