Status pages very slow on one of the two appliances in a cluster
Originally Published: 2011-07-29
Article Number
Applies To
Issue
/KMS and /rkmawa perform fine, but /status or /status/db page shows up very slow (with a delay of ~5min)
Reinstalling status pages does not solve the problem; restarting Tomcat does not solve the problem either
When the following script (part of the status pages) is run on the shell prompt, there is no output for the command and it returns after a delay of about 5 min:
"/opt/tomcat/webapps/status/shared/originalHostname.sh S"
For example:
cd /opt/tomcat/webapps/status/shared
[root@rkm01 shared]# ./originalHostname.sh S
[root@rkm01 shared]#
/opt/oracle/product/10.2.0/db_1/network/admin/tnsnames.ora on the primary appliance, where the problem occurs, has following contents:
# Generated by RSA KM configuration tools
LISTENER =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm01.test.net)(PORT = 1521))
)
)
EXTPROC_CONNECTION_DATA =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
)
(CONNECT_DATA =
(SID = PLSExtProc)
(PRESENTATION = RO)
)
)
#---------------------------------------
# Added on: xxxxxx
# Added by: install_primary
#---------------------------------------
QARKM =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm01.test.net)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = QARKM)
)
)
#---------------------------------------
# Added on: xxxxxx
# Added by: install_primary
#---------------------------------------
QARKMP =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm01.test.net)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = QARKM)
)
)
#---------------------------------------
# Added on: xxxxxxx
# Added by: install_primary
#---------------------------------------
QA.RKM01.TEST.NET =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm01.test.net)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = QARKM)
)
)
#---------------------------------------
# Added on: xxxxxxx
# Added by: install_primary
# Note: This TNS is a single line of record.
#---------------------------------------
QA.WORLD = (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = rkm01.test.net)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SID = QARKM) ) )
/opt/oracle/product/10.2.0/db_1/network/admin/tnsnames.ora on the secondary appliance, where the problem does not occur, has following contents:
# Generated by RSA KM configuration tools
LISTENER =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm02.test.net)(PORT = 1521))
)
)
EXTPROC_CONNECTION_DATA =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1))
)
(CONNECT_DATA =
(SID = PLSExtProc)
(PRESENTATION = RO)
)
)
#---------------------------------------
# Added on: xxxxxx
# Added by: install_standby
#---------------------------------------
QARKM =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm02.test.net)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = QARKM)
)
)
#---------------------------------------
# Added on: xxxxxxx
# Added by: install_standby
#---------------------------------------
QARKMP =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm01.test.net)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = QARKM)
)
)
#---------------------------------------
# Added on: xxxxxxx
# Added by: install_standby
#---------------------------------------
#---------------------------------------
QARKMS =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm02.test.net)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = QARKM)
)
)
#---------------------------------------
# Added on: xxxxxx
# Added by: install_standby
#---------------------------------------
QA.RKM01.TEST.NET =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm01.test.net)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = QARKM)
)
)
#---------------------------------------
# Added on: xxxxxx
# Added by: install_standby
#---------------------------------------
QA.RKM02.TEST.NET =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm02.test.net)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = QARKM)
)
)
QA.WORLD = (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = rkm01.test.net)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SID = QARKM) ) )
Cause
A) tnsnames.ora on the primary appliance (rkm01) needs to be corrected (to add missing records for QARKMS/RKM02)
B) DNS is incorrect (in resolv.conf) on the primary appliance (rkm01) network config which results in a timeout delay (of ~5 min), as tnsping tries to use the name (not found in tnsnames.ora) as a hostname which times out due to incorrect DNS config
Resolution
A) To fix the problem with tnsnames.ora on the primary (rkm01), update /opt/oracle/product/10.2.0/db_1/network/admin/tnsnames.ora on rkm01 to add the following two missing blocks:
#---------------------------------------
# Added on: <today's date>
# Added by: manually
#---------------------------------------
QARKMS =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm02.test.net)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = QARKM)
)
)
#---------------------------------------
# Added on: Monday, April 04, 2011
# Added by: manually / C11239833
#---------------------------------------
QA.RKM02.TEST.NET =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = rkm02.test.net)(PORT = 1521))
(CONNECT_DATA =
(SERVER = DEDICATED)
(SID = QARKM)
)
)
B) To fix the problem with DNS configuration, review and compare /etc/resolv.conf on both primary (rkm01) and secondary (rkm02). Verify that DNS is correctly configured on both appliances. If contents are different on the two nodes, most likely the config on the secondary is correct as it does not exhibit the problem. If needed, edit and correct nameserver records in /etc/resolv.conf using vi on rkm01 and/or rkm02.
Related Articles
Zoho One - SAML My Page SSO Configuration - RSA Ready Implementation Guide 12Number of Views When approval activities are grouped by category, they auto-complete when one of the items is rejected in RSA Identity Gov… 90Number of Views Installation fails with 'unzip: cannot find zipfile directory in one of /tmp/aveksa/packages/<filename.zip>' error in RSA … 54Number of Views Exporting a set of One Time Tokencodes from RSA Authentication Manager Self-service Console 96Number of Views Splunk Cloud - SAML My Page SSO Configuration - RSA Ready Implementation Guide 49Number of Views
Trending Articles
RSA Authentication Manager Upgrade Process RSA Release Notes for RSA Authentication Manager 8.8 RSA RADIUS Server service failed to start in the RSA Authentication Manager 8.1 Operations Console Microsoft Entra ID External MFA - Relying Party Configuration Using OIDC - RSA Ready Implementation Guide RSA Release Notes: Cloud Access Service and RSA Authenticators
Don't see what you're looking for?