Access Manager servers are slow to start up.
Originally Published: 2012-11-22
Last Modified: 2023-10-06
Article Number
Applies To
Red Hat Linux Enterprise
VMWare ESX Server
RSA Access Manager is configured for ANON or AUTH SSL.
Issue
The RSA Access Manager servers are slow to start up. There are no error messages logged. The problem appears to be intermittent and the time to startup is sometimes a minute, sometimes as long as 10 minutes. The pause seems to occur during creation of the servers listen port.
If the servers is started with -DDEBUG_FULL you can see that there is a pause during the SSL initialization.
2012/11/21 15:15:12:206 [ssl] [main (sirrus.util.net.SSLSocketFactory.setEnabledCipherSuites)] - Available Ciphers:
2012/11/21 15:47:30:593 [ssl] [main (sirrus.util.net.SSLSocketFactory.printCiphers)] - Cipher[0]: SSL_RSA_WITH_RC4_128_MD5
Cause
The following articles provide more information:
6521844 : SecureRandom hangs on Linux Systems
Resolution
An alternative is to direct the crypto libraries to use an alternate source for the randomness. Linux has an alternate file called urandom that can be used for this purpose. Note that potentially using a random source with less entropy could reduce the robustness of some crypto features.
You can either modify the global java security.properties file and add the following line:
securerandom.source=file:/dev/./urandom
Or you modify the server startup batch files to pass the following parameter to each instance of the JVM that is started.
-Djava.security.egd=file:/dev/./urandom
Note that the security.properties file may already have a line that says "securerandom.source=file:/dev/urandom" which is similar to the example above but with a path that does not contain a dot. Due to the way file handles are passed to JAVA by some operating systems this setting is ignored in this format. You must include a "." (dot) in the path for the setting to be effective.
Related Articles
Authentication Manager Administration Server with operations console service Fails to Start with "No config.xml Was Found"… 1.76KNumber of Views AFX Server stuck in 'Not running' State, with error 'timed out waiting for AFX applications to start' 3.67KNumber of Views AFX Server Fails to Start with 'Could Not Build a Validated Path' and 'Timed Out Waiting for AFX Applications to Start' in… 1.22KNumber of Views Authentication Manager Administration Server with Operations Console Fails to Start – Error Keywords: CertificateExpiredEx… 3.04KNumber of Views How to Forward RSA Authentication Manager 8.4 or Later Logs to Multiple Syslog Servers Using rsyslog 1.98KNumber of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory How to verify NTP server synchronization is not working in RSA Authentication Manager 8.x RSA Governance & Lifecycle 8.0.0 Installation Guide
Don't see what you're looking for?