Article Number
000031129
Applies To
RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.1
Issue
When trying to change a password or PIN in the Self-Service Console, the error “Invalid argument(s)” displays as in the screenshot below:
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Cause
This error displays when there is an issue with the Self-Service email notification template settings.
To resolve the issue, check the /opt/rsa/am/server/logs/imsConsoleTrace.log for an error like "InvalidArgumentException".
In the example below the error is related to the cc field having an invalid semi-colon:
com.rsa.command.exception.InvalidArgumentException: Invalid 'cc' address: email1@example.org;email2@example.org
Resolution
This can be resolved by following the below steps:
1- Open the Security console -> Setup -> Self-service settings .
2- Under Customization open E-mail Notifications for User Account Changes .3- Under Email-template remove the semi-colon and replace it by a comma as shown in the below screenshot.
4- Click save.
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