AM8.1 Server contact List AutoRebalance Error
3 months ago
Originally Published: 2015-03-25
Article Number
000060137
Applies To

RSA Product Set: SecurID
RSA Product/Service Type: Authentication Manager
RSA Version/Condition: 8.1.0 AM 8.1 SP1
Platform: Linux
Platform (Other): null
O/S Version: SUSE Linux
Product Name: null
Product Description: null

Issue

AM8.1 Server contact List AutoRebalance Error, AutomaticRebalance error, Auto Re-balance Error
AM 8.1 Automatic Rebalance of Server contact list fails with Error: 

There was a problem processing your request.Unexpected error during command com.rsa.authmgr.admin.servermgt.SynchronizeAgentProtocolServerListsCommand execution

 

Cause

This is because of invalid data in the exiting contact list, something wrong with the name or IP address of one of the replicas.

Resolution

1- From the top Security Console menu select Access/Authentication Agents/Authentication Manager Contact List/Manage Existing.


contactList 


2- Then from the Drop down click on Edit

3- Check the list of Replicas in the Contact list on the right, if any are spelled wrong, has a missing or incorrect IP address or if the one that was deleted is on the right, move it to the left/Available side or delete it.
4- Make sure that the "NAME" matches the "SERVER NODE" Selected.
5- Once the name is corrected, save and then run Automatic Rebalance.

Note: This behavior can also be seen if there is an invalid contact list. To resolve this issue, delete the secondary contact list (One of the replica) and run Automatic Rebalance again to generate a new one.

Workaround

1- Flush Cache in the Operations Console or patching may fix this. Flush the Cache

2- Edit each of the Automatic Contact Lists for each of the Primary and Replicas, move all servers out so that only the Server itself is left in the contact list for itself, and Save.  Also delete any Non-Automatic Contact lists.

3- Then try the automatic rebalance after you have edited all Automatic Contact lists