AFX Server on Windows fails to stop/start after initial successful start in RSA Governance & Lifecycle
Last Modified: 2024-01-15
Article Number
Applies To
- RSA Governance & Lifecycle 8.0
Issue
When stopping or starting the AFX service, the command line window quickly disappears and does not properly run. The expected behavior is for a command line window to appear and complete the stop or start process and then prompt the user to press any key to close the window.
When the service fails to stop or start, the following is logged in afx_windows.log:
Mon 11/27/2023 13:05:41.94
Starting task "stop"
Checking for access rights
Access rights available
The syntax of the command is incorrect.
This issue can also result in a failure to auto-upgrade the AFX server from version 8.0 to 8.0.0 P01, when the RSA Governance & Lifecycle Cloud is upgraded from 8.0 to 8.0.0 P01, as the auto-restart (a required step in the upgrade process) of AFX server would fail.
Cause
C:\Users\Administrator>echo %JAVA_HOME% C:\Program Files\Eclipse Adoptium\jdk-8.0.362.9-hotspot\Then the AFX Server stop/start script incorrectly updates the path set in the System Variable JAVA_HOME by replacing the backslash character (\) with a double-quote character ("), hence corrupting the path to the JDK.
Resolution
- RSA Governance & Lifecycle 8.0.0 P02
Workaround
To do so, login as an administrator on the Windows host, right-click Start > System > Advanced System Settings (under Related settings) > Advanced tab > click Environment Variables... > select JAVA_HOME under System variables > click Edit to update the path, then click OK > OK again to save the changes.
Notes
Related Articles
How to Start/Stop/Access Oracle Enterprise Manager (OEM) in RSA Governance & Lifecycle 188Number of Views Error: ' (RSALogger.java:764) - [CSF-InitializationFailed: ] The system has not been initialized.' appears in logs during … 10Number of Views 'No such service afx_server' error when performing afx status/stop/start commands in RSA Identity Governance & Lifecycle 147Number of Views Application is inaccessible and 'javax.naming.NamingException: Could not dereference object' error when stopping RSA Ident… 67Number of Views After patching a Request Could Not be Handled error appears when pressing Edit Log Settings for Connectors in RSA Governan… 3Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?