Data Feed is failing with error Unable to login with specified credentials
2 years ago
Originally Published: 2020-09-16
Article Number
000042500
Issue
 Customer was getting below error 

<Description>Unable to login with specified credentials</Description>
<DataFeed>xxx</DataFeed>

<StackTrace>
at ArcherTech.Utility.AccessControl.SessionContextAdministrator.CreateSession(String instanceName, String userName, String password, String userDomain)
at ArcherTech.Utility.AccessControl.SessionContextAdministrator.GetSessionContext(String instanceName, String userName, GetPassword getPasswordDelegate, String userDomain)
at ArcherTech.DataFeed.Workflows.Activities.CreateServiceSessionContextActivity.Execute(ActivityExecutionContext executionContext)
at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)
at System.Workflow.Runtime.Scheduler.Run()
</StackTrace>

Checked the Security Event report and we noticed the "userArcherDataFeedService" failing to login.

 Checked the tblUser table and the "userArcherDataFeedService" is not locked
select * from tblUser where user_username = 'userArcherDataFeedService'

If you are running very frequently (every 1 - 15 mins) Datafeed, it is the best practice to create separate account for them (the username in the Transport tab). For instance if you use one account for all the Data Feeds if the account is used by more than one Data Feed, then the Data Feed my fight each other and they will conflicts each other session. Please avoid potential conflicts with other data feeds, RSA suggests that you use a different user account for each data feed. Additionally, if you plan to run multiple data feeds simultaneously,create a unique name to prevent termination of session tokens. Data Feed Manager supports standard and transport data feeds. It mentioned in the Archer installation and update guide page 52

Increased the Archer Services Parameter Session Timeout from 30 minutes (default) to 6 hours:
KB 000029541 https://community.rsa.com/docs/DOC-47814

Rest the Service account in the Archer Control Panel. Restart the Archer services and II service.

We ran some tests for the File Transporter Data Feeds and change the schedule time. The feeds completed successfully 

 
Cause
 Checked the tblUser table and the "userArcherDataFeedService" is not locked
select * from tblUser where user_username = 'userArcherDataFeedService'



Increased the Archer Services Parameter Session Timeout from 30 minutes (default) to 6 hours:
KB 000029541 https://community.rsa.com/docs/DOC-47814

Rest the Service account in the Archer Control Panel. Restart the Archer services and II service.

We ran some tests for the File Transporter Data Feeds and change the schedule time. The feeds completed successfully