Error message "The use of public webmail services is not supported. Please try again with a valid business email address"
Originally Published: 2017-11-29
Last Modified: 2026-07-06
Article Number
Applies To
Issue
When attempting to register for an RSA Community and/or myRSA account, the error message below is displayed after entering my email address.
The use of public webmail services is not supported. Please try again with a valid business email address
Cause
Resolution
If you believe that you are seeing this message in error and that your email domain should be accepted, please contact RSA Customer Support and reference this article for further assistance.
Notes
Attachments
If the attachment does not open when clicked, please refresh the page and try again. You must be logged into view the file(s).
Related Articles
RSA SecurID Authentication Agent 8.0 for Web for Apache Web Server displays error: 106: Web server too busy. Please try… 101Number of Views Cannot log into the Security Console. Error is 'authentication error' and 'session expired' and 'please try again' in RSA … 233Number of Views Resetting Password for LDAP Directory Server User in the Cloud Console Fails With Error “Unable to reset password! Please … 100Number of Views RSA SecurID: Identity Sources configurations "You have reached the limit of ldap resources you can add please remove a re… 38Number of Views Error: 'The user is not enabled for authentication. Please contact your administrator.' in RSA Mobile 20Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?