Form control type 'Drop Down Select with Web Service' displays Unauthorized error in RSA Identity Governance & Lifecycle 7.1.1
Originally Published: 2019-04-22
Last Modified: 2022-06-20
Article Number
Applies To
RSA Version/Condition: 7.1.1, 7.2.x
Issue
- When designing a custom form in RSA Identity Governance & Lifecycle (go to Requests > Configuration > Request Forms tab> {Request form name} Fields > New > General tab), if the Control Type Drop Down Select with Web Service is used to return a response from a Web Service command as in the example below:
The Admin API call returns the WebService Result response of Unauthorized. - When attempting to call a WebSerivce command from within a workflow the following error occurs.
"Error 401: The token is required for the command {command name}"Cause
In RSA Identity Governance & Lifecycle 7.1.1, the RSA Admin API Web Service commands now require that a token be passed for authentication. The Control Type Drop Down Select with Web Service dialog does not currently have a method to pass a token to the Web Service command.
More information about the token requirement can be found in the online Web Services documentation under Admin > Web Services > under Admin Commands > about:
The command expects the following parameters where a * denotes a required parameter:
token* - Session token, retrieved from loginUser. This token must be valid and unexpired.
Resolution
This issue is resolved in the following RSA Identity Governance & Lifecycle versions and/or patch levels:
- RSA Identify Governance & Lifecycle 7.1.1 P02
- RSA Identity Governance & Lifecycle 7.2.0
- RSA Identity Governance & Lifecycle 7.2.1
Related Articles
Unauthorized message for Drop Down Select with Web Service in RSA Identity Governance & Lifecycle 54Number of Views Form element control type "Drop Down Select with Web Service" displays validation exception as a value in RSA Identity Gov… 63Number of Views When should a Provisioning-Termination Rule delete accounts in RSA Identity Governance & Lifecycle? 198Number of Views Provisioning Termination rule is not generating change requests to disable accounts in RSA Identity Governance and Lifecycle 131Number of Views The inserted smart card is not from the cardset 'Corporate' Please insert the correct smart card. 9Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?