ORA-01403: no data found error in Account Data Collectors (ADC) in RSA Governance & Lifecycle
2 years ago
Article Number
000069904
Applies To

This is a known issue in the following version.

  • SecurID Governance  & Lifecycle 7.5.2
  • RSA Governance & Lifecycle 8.0.0
Issue

Account Data Collectors (ADC) may fail in step Account Data Object Processing.

 

The following error is logged in the aveksaserver.log file

09/21/2023 13:22:20.066 ERROR (Exec Task Consumer#0 - Accounts Sequence) [org.hibernate.engine.jdbc.spi.SqlExceptionHelper] ORA-01403: no data found
ORA-06512: at "AVUSER.COMMON_EXPLODER", line 1414
ORA-06512: at "AVUSER.COMMON_EXPLODER", line 1414
ORA-06512: at "AVUSER.ADC_DATA_COLLECTOR", line 258
ORA-06512: at "AVUSER.ADC_DATA_COLLECTOR", line 514
ORA-06512: at line 1

 

 

Cause

This can occur on the next run of a particular Account Data Collector (ADC) after previous run of the collector commanded a full refresh.  The issue occurs if for some reason the previous data collection run of the particular ADC is no longer available. 

There are a variety of reasons why a full refresh of the ADC might be commanded but the most common reasons is during the first run of the collector after a data migration from a previous version.  This issue is therefore typically seen after a data migration. 

Resolution

This issue is resolved in the following version.

  • SecurID Governance & Lifecycle 7.5.2 P09
  • RSA Governance & Lifecycle 8.0.0 P01
This problem may sometimes be resolved temporarily (for this run) by running a full refresh on the problem collector.  
Workaround

Contact RSA Customer Support if you cannot patch to the version where this is resolved.



 
Notes