Oracle Database Collector fails with "ORA-01017:invalid username/password" in RSA Identity Governance & Lifecycle
Originally Published: 2019-05-08
Last Modified: 2022-06-20
Article Number
Applies To
RSA Version/Condition: 7.0.2, 7.1.0, 7.1.1
Issue
java.sql.SQLException: ORA-01017: invalid username/password; logon denied
The /home/oracle/wildfly-8.2.0.Final/standalone/log/aveksaServer.log shows the following ERROR level log message:
05/08/2019 15:16:27.292 ERROR (Thread-6499 (HornetQ-client-global-threads-1354152125)) [com.aveksa.server.utils.NodeMessageBroker] Exception while getting test data from collector com.aveksa.server.runtime.ServerException: com.aveksa.sdk.collector.CollectionException: com.aveksa.common.DataReadException: ERROR: Could not get accounts data: . Caused by com.aveksa.common.DataReadException: ERROR: Could not get accounts data: . Caused by java.sql.SQLException: ORA-01017: invalid username/password; logon denied .. Caused by: java.sql.SQLException: ORA-01017: invalid username/password; logon denied
Cause
This is a known issue if the Oracle bind password contains certain special characters. RSA Identity Governance & Lifecycle currently sanitizes input in the Password dialog box of the collector to prevent potential scripting attacks. Although these characters are valid characters allowed by Oracle as part of the Oracle password, they cannot be used in the password dialog box.
The list of characters currently known to cause this issue are the following.
- # - number sign, also known as pound or hash character
- $ - dollar sign
- _ - underscore or underline
Resolution
Workaround
- # - number sign, also known as pound or hash character
- $ - dollar sign
- _ - underscore or underline
Related Articles
RSA Identity Governance and Lifecycle7.0.2 installation with remote database fails with "Invalid Username/Password" in the… 210Number of Views Upgrade of RSA Governance and Lifecycle from 7.0.0 to 7.0.1 fails with Checking database... Invalid Username/Password 239Number of Views Unable to create connection to the database using Oracle 12 pluggable database as remote database on RSA Via Lifecycle & G… 19Number of Views ORA-01017: invalid username/password; logon denied . For details refer to "(:CLSN00107:)" when attempting to start the dat… 414Number of Views Unable to delete Object while connected to the HOST node in a cluster setup in RSA Governance & Lifecycle 7Number of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Unable to login to RSA Authentication Manager Security Console as super admin RSA MFA Agent 2.3.6 for Microsoft Windows Installation and Administration Guide Manual synchronization introduced in RSA Authentication Manager 8.2 Service Pack 1 patch 6 Quick Setup Guide - Passwordless Authentication in Windows MFA Agent for Active Directory
Don't see what you're looking for?