RSA Authentication Manager Prime services fail to start after Java update on a Windows server: Error Failed creating java
Originally Published: 2015-08-17
Last Modified: 2023-10-06
Article Number
Applies To
RSA Product/Service Type: Authentication Manager, Authentication Manager Prime
RSA Version/Condition: 8.1, 1.x
Platform: Windows 2008 or WIndows 2012
Platform (Other): Tomcat
Issue
The tomcat commons-daemon.date.log for each service report the following error:
[2015-08-17 10:34:08] [info] [ 1812] Commons Daemon procrun (1.0.15.0 64-bit) started
[2015-08-17 10:34:08] [info] [ 1812] Running 'Tomcat7-AMIS' Service...
[2015-08-17 10:34:08] [info] [ 2736] Starting service...
[2015-08-17 10:34:08] [error] [ 2736] Failed creating java C:\Program Files\Java\jre1.8.0_45\bin\server\jvm.dll
[2015-08-17 10:34:08] [error] [ 2736] The system cannot find the path specified.
[2015-08-17 10:34:08] [error] [ 2736] ServiceStart returned 1
Logs for Tomcat are typically going to be in C:\RSA\Tomcat7-AMIS\Logs. Note for each AMIS item there is a different Tomcat7 folder instance. In this case, refer to the commons-daemon.<date>.log which will contain the current date in place of the word date. Cause
When Tomcat starts it looks for the Java Virtual Machine path defined in the Tomcat configuration and can no longer find the jvm.dll file it needs to start. The path started out as C:\Program Files\Java\jre1.8.0_45\bin\server\jvm.dll which causes the error during startup.
Resolution
- Right click the first Tomcat icon for the AMIS framework service, then click Configure...
- Check the Java path details by going under C:\Program Files\Java\ and making note of the newer folder with the higher end number. In this case it's 51, but in the future it may be 52 or above.
- Set the path under the Tomcat Config > Java.
- Click Apply or OK.
- Repeat steps 1 - 4 for any other AMIS Prime Tomcat services you have on the server such as for the Self-Service Portal or Help Desk Admin Portal currently.
- Right click and stop/start each Tomcat instance. All services should now be running as expected.
Related Articles
Prime kit tomcat.pid: Permission denied error when restarting services for RSA Authentication Manager Prime Kit 107Number of Views RSA Authentication Manager Prime throws "Node secret mismatch: cleared on server but not on agent" despite repeated cleari… 540Number of Views Collect Prime logs and Configuration files using the collect script 179Number of Views Determining an existing RSA Prime version 54Number of Views Authentication Manager Prime: SSP Keystore Import Fails with "Failed to Establish Chain from Reply" 1.39KNumber of Views
Trending Articles
How to manipulate imported RSA SecurID Software Token(s) on an iPhone or iPad device Reporting on RSA Authentication Manager 8.x users with On-Demand Token, a fixed passcode or a hardware/software token assi… How to Download OTP Token Seed Files from myRSA Anomalix idGenius - SAML Relying Party Configuration - RSA Ready Implementation Guide RSA MFA Agent 2.5 for Microsoft Windows Installation and Administration Guide
Don't see what you're looking for?